1

I've started getting this error when trying to Access Magento downloader, the rest of the site work:

The PDO extension is required for this adapter but the extension is not loaded

Been searching for a fix, but didn't find one...

My php.ini at the bottom has everything that is suggested, it worked before... I don't know what happened..

I had complier enabled, then wanted to install a new extension, so disabled the complier and this happened.

Deleted everything manually form Cache folder and nothing.

I have this in the php.ini, any ideas?

extension=pdo.so
extension=pdo_sqlite.so
extension=sqlite.so
extension=pdo_mysql.so

Thanks,

  • Does PDO show up in phpinfo()? – Jonathan Hussey Nov 14 '14 at 12:48
  • Yes, PDO Support - Enabled – Artur Rain Nov 14 '14 at 12:49
  • Have you re-run compilation, cleared cache etc etc? – Jonathan Hussey Nov 14 '14 at 12:50
  • How to correctly re-run compilation? Cache, cleared multiple times inside of magento and manually var/cache – Artur Rain Nov 14 '14 at 12:52
  • Just run compilation under system->tools->compilation – Jonathan Hussey Nov 14 '14 at 12:52
1

Ok, found the Issue, downloader page was missing the PHP.ini.

Copied and pasted the same PHP.ini from the public_html directory to the downloader directory and it started working..

But I don't like this solution, because checked the default Magento instalation and php.ini is not present in the Downloader directory and I don't know, did I hack it or else... If someone has a clue, what could have happend, please post your answer.

Best wishes,

|improve this answer|||||
  • usually you have a central php.ini in your server config folder. But depending on your hoster, you are maybe not allowed to set these. – Flyingmana Nov 14 '14 at 15:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.