0

We have the below error displaying in the browser when we navigate to Catalog > Manage Categories

Fatal error: Call to undefined method Mage_Catalog_Model_Resource_Category_Flat::loadAllAttributes() in /includes/src/__default.php on line 27697

We have compiler enabled. When compiler is disabled the error reads:

Fatal error: Call to undefined method Mage_Catalog_Model_Resource_Category_Flat::loadAllAttributes() in /app/code/local/Mage/Catalog/Model/Category.php on line 289

When we change "use flat catalog category" to disabled, the error disappears and we can use our manage categories area as normal. This only started occuring after upgrading to Magento 1.8 from 1.7.0.2 last week.

We have tried reindexing all processes etc, but no change.

Everything else in our site is fine, we just cannot access this page from the admin area! :(

Any ideas on how to resolve?

  • Can Turn off flat catalog, leave compilation off, clear cache, re-index then try turning on flat catalog – brentwpeterson Oct 6 '13 at 1:03
  • Hi Brent, we tried this previously, but no joy. Deleting/renaming the local category.php file worked for us. Cheers. – MagentoMac Oct 6 '13 at 10:26
2

Delete file from local folder (or rename it to keep changes if you need them). Magento will use original file and there will be no error more.

/app/code/local/Mage/Catalog/Model/Category.php
  • Success :) Many thanks for your help here. You've saved our bacon ;) – MagentoMac Oct 6 '13 at 10:27
1

The issue here is obviously that the file /app/code/local/Mage/Catalog/Model/Category.php was not upgraded along with your 1.8 upgrade exercise. This is why I do not recommend copying to the local code pool*.

The solution is probably not to remove the file and allow it to fall back down to the app/code/core version as the changes were likely made for some reason - the solution is a multi-step process:

  • Compare the app/code/local version with your old 1.7.0.2CE file version. I've gone ahead and compared it - this is just one of the many changes to the class file in 1.8:

enter image description here

  • There will likely be differences. Make note of these differences - you're going to merge them into a class rewrite later.
  • If there are other files in app/code/local/Mage/Catalog/* repeat the above step until all changes have been reviewed.
  • Add the changes to a class rewrite of the file in a local module, taking care to duplicate the functionality from the 1.8CE version of the module.

The more pervasive the changes are the more work it will require to merge them into the new 1.8 version of the code.

* This is such a common problem, in fact, that code pools have been removed from Magento 2 entirely.

0

I also got this problem after upgrading from CE 1.7.1 to 1.8.1 and it seems to be fixed after renaming:

/app/code/local/Mage/Catalog/Model/Category.php

to

/app/code/local/Mage/Catalog/Model/Category.php.disasabled

although @philwinkle solution seems to be more logical.

Another thing I am almost sure is related to this issue is that after upgrade I also got duplicated tables in my bbdd:

catalog_category_flat (empty)

and

catalog_category_flat_store_1 (seems the one to be used)

But if I delete anyone of them "category flat data" fails to reindex as well as "Manage Store Crash"

  • The first section about the file remain. Seems that you had a local copy of the category model which wont have been updated but would still be used and thus could cause errors – David Manners Jan 11 '14 at 16:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.