2

With Apache2.4 mariaDB php7.0.2 everything working correctly with php7 extensions except for my products dont display when searched in magento2 Front-end. After checking for anything that could have changed I updated my Cron jobs to

*/1 * * * * php -c /etc/php/7.0/cli/apache2 /var/www/html/magento2/bin/magento cron:run
*/1 * * * * php -c /etc/php/7.0/cli/apache2 /var/www/html/magento2/update/cron.php
*/1 * * * * php -c /etc/php/7.0/cli/apache2 /var/www/html/magento2/bin/magento setup:cron:run
*/1 * * * * php -c /etc/php/7.0/cli/apache2 /var/www/html/magento2/bin/magento indexer:reindex

Each command runs perfectly manually But when i go to the Admin-Backend this is what I get in the Index section. Indexer processing

After searching for anyone else I seen on here that @Alex Paliarush said you have to run this command to fix stuck at processing.

 update magento.indexer_state set status='invalid' where status ='working'

So i ran this command in SQL via phpmyadmin the sql was successful but it fixed half the problem the Catalog search is still processing. so I stopped cron jobs and ran the sql query again then manually ran Indexer:reindex and got this error.

Customer Grid index has been rebuilt successfully in 00:00:00
Category Products index has been rebuilt successfully in 00:00:00
Product Categories index has been rebuilt successfully in 00:00:00
Product Price index has been rebuilt successfully in 00:00:00
Product EAV index has been rebuilt successfully in 00:00:00
Stock index has been rebuilt successfully in 00:00:00
Catalog Rule Product index has been rebuilt successfully in 00:00:00
Catalog Product Rule index has been rebuilt successfully in 00:00:00
Segmentation fault (core dumped)

So this Fixed my Customer Grid indexer and left me with this. Magento2 Indexer Catalog Search

I believe because the indexer isn't correctly indexing my products its causing them to not show up on the frontend of the site i didn't have this problem on php5.6

I enabled php7.0-cli log to find the error when running indexer here's what i have gotten.

[10-Jan-2016 11:19:36 UTC] PHP Fatal error:  Allowed memory size of 1073741824 bytes exhausted (tried to allocate 140022063078552 bytes) in /var/www/html/magento2/lib/internal/Magento/Framework/Model/AbstractModel.php on line 442

So some how there is a bug thgats trying to use over 140 terabytes.

2

@acidreian PHP7 issues have been fixed in tag 2.0.1 Please try and let us know if your issue has been fixed.

  • So after having issues upgrading to 2.0.1 then finally getting it to work by using my fix I have posted in link Then updating to back to php 7.0.2. Then I updated to 2.0.2 using My fix in composer once again (with the php7 patch already applied) because system Upgrade is a joke. I have a fully functional apache2.4 php7.0.2 Magento 2.0.2 working. No problems as of yet its only been 1 day though. – acidreian Jan 30 '16 at 23:40
0

Thats seems to be just SQL code. You can run it from the commandline when you log into your database. Or you could run it from a webtool like phpmyadmin if you are using mySQL.

  • So i updated my results and still having the problem. – acidreian Jan 10 '16 at 10:41
  • Segmentation fault means: 1. Very basically, it means your program is trying to access a memory area it is not suposed to. 2. To the current directoy. 3. You need to make sure your program doesn't do 1.. From following topic. See for more details: ubuntuforums.org/showthread.php?t=2071988 – Akif Jan 10 '16 at 11:25
  • added Php7.0-cli log with the error output for the SegFault. – acidreian Jan 10 '16 at 11:33
  • 140 terabytes? I see 1073741824 bytes. What is the memory limit now? Did you try to increase it yet? – Akif Jan 10 '16 at 11:36
  • my memory limit is 1024M, 1073741824 bytes = 1.07 GB. 140022063078552 bytes is how much memory the AbstractModel.php on line 442 tried to allocate which is = 140.02 Terabytes. – acidreian Jan 10 '16 at 21:16
0

Looks like this is problem in php7.0.x with yield operator. In some specific case it will SegFault (like in Magento/CatalogSearch/Model/Indexer/Fulltext/Action/Full.php:378).

  • So should this be submmited as core problem with php7.0.x? – acidreian Jan 10 '16 at 21:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.