2

I am creating a new PDF Invoice and most is fine but the one thing that I just cannot find is how to change the text of the 'totals' block at the end!

Currently this shows

Subtotal
Shipping & Handling
Grand Total

and I want it to show

Sub Total
Delivery
Total

Should be very easy and I expected to be able to overwrite the values in my local locale translate.csv file with an entry such as

"Shipping & Handling","Delivery"

but it doesn't work!

Cache cleared, etc. but no change on the invoice. What am I missing?

Or can anyone tell me how to get these values from the order so I can craft the lines myself?

Magento 1.9.0.1

3

These Labels are coming from Mage/Sales/etc/config.xml between line 1443 and 1480 I am not sure where in the admin section they are present, if they are present there.

But you can always change them from .csv files

For example, I did it from here

app/locale/en_US/Mage_Sales.csv

like this

"Shipping & Handling","Delivery"
"Shipping & Handling","Delivery"

You need to do it for your own language.

Thanks.

  • I'd alreasdy tried changing the values as suggested in app/locale/en_US/Mage_Sales.csv but nothing changed. I've got country set to United Kingdom which, as I understand it, uses 'en_US'. I notice also that the theme I'm using has a translate.csv file which seems to be being ignored. It may be in some strange way connected. – Ken Oct 31 '14 at 13:09
  • Did you flush the cache? – Nasir Perwaiz Oct 31 '14 at 13:21
3

Go app\design\adminhtml\default\default\locale\en_US

translate.csv

Add your text where u want to change first column Shipping & Handling second column on you want a text.

Add your label translate list on this file.

enter image description here

enter image description here

  • I can see that yours clearly worked but mine doesn't! I'd already tried and overwrite in app\design\adminhtml\default\mytheme\locale\en_US and that hadn't worked so I was a bit excited that your answer would have hit on the answer I needed but there must be something else strange going on! :-( – Ken Oct 31 '14 at 14:17
  • I changed the core file code/core/Mage/Sales/etc/config.xml and the changes I want show up, but when I try to do it by overwriting, having a copy in code/local/Mage/Sales/etc/config.xml and changing it there, it doesn't work. Is that not the right way to change things? I'd really rather not change core files. – Ken Oct 31 '14 at 15:47
0

If you want to override it, don't use

"Subtotal","Sub Total"

Use it like this

"Mage_Sales::Subtotal","Sub Total"

Since this translation is located in the Mage_Sales.csv file

0

I had the same problem and I couldn't see the changes afer i added translation to translate.csv

If you change translate.csv in directory below

app\design\adminhtml\default\default\locale\en_US

Make sure your locale option in Settings is set to the English US rather than English UK that was my mistake.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.