0

I am trying to update a 2.2.8 store to 2.4.3-p1. This is what I did:

composer require magento/product-community-edition=2.4.3-p1 --no-update
composer update

After a while this was done, so I ran:

php bin/magento setup:upgrade

Here I am getting the Your current search engine, 'MySQL', is not supported. error. Makes sense since in Magento 2.2 there was no other option. So I searched a bit and found I should run

php bin/magento config:set catalog/search/engine elasticsearch7

When I run this, I am getting Base table or view not found: 1146 Table 'queue_poison_pill' doesn't exist. Now I am stuck here, any ideas how to fix that?

Used PHP is 7.4

Thanks!

1 Answer 1

0

Create the missing table in Database run below query.

SET SQL_MODE = "NO_AUTO_VALUE_ON_ZERO";
SET AUTOCOMMIT = 0;
START TRANSACTION;
SET time_zone = "+00:00";

CREATE TABLE `queue_poison_pill` (
  `version` varchar(255) NOT NULL COMMENT 'Poison Pill version.'
) ENGINE=InnoDB DEFAULT CHARSET=utf8mb3 COMMENT='Sequence table for poison pill versions';
3
  • Had the same idea in the meantime and it works! Thanks Mar 10, 2022 at 12:43
  • @user4095519 Welcome!! Mar 10, 2022 at 13:36
  • @user4095519 if it's help full to you so please upvote because other user fetch this kind of error so it's easily help Mar 14, 2022 at 10:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.