I am working on a client project and set up a development copy of the live site, front is working fine but admin is broken because of the fishpig wordpress integration actually i dont to set wordpress so didnt copy the db for this and want to disable the extension i disable the
by setting false in module config file under /app/etc/modules file and refresh the cache but the admin is not working log folder has wordpress.log file which is saying

2013-05-01T19:14:40+00:00 DEBUG (7): SQLSTATE[HY000] [2002] Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock' (2)

also the cache is enabled looking for disable it from mysql and compilation is enabled too and admin is not opening :'(

Any body having any idea.

3 Answers 3


Just rename the directory

./app/code/community/Fishpig -> ./app/code/community/Fishpig.bak

That will disable it outright.

Disabling the module via the admin, or via ./app/etc/modules doesn't always work if another class extends that class anyway.

You can disable the cache by removing the ./var/cache directory (or by restarting Memcache/Redis/APC if you use them)

You can disable compiler by commenting out the include $compilerConfig line in index.php

  • Thanks a lot for your answer very informative but this didn't solved the error but as i see wordpress.log is not coming up in log folder anymore. May be some other issue is ditching me..
    – Ravi Soni
    Commented May 2, 2013 at 18:10
  • 1
    You asked how to disable a module and clear the cache. If you want to debug an issue, follow the debug guide here sonassi.com/knowledge-base/magento-debug-process - it will identify your issue. Commented May 2, 2013 at 21:27
  • Thx for debug stpe i have already tried some steps. front is good .. could my theme cause broken admin?
    – Ravi Soni
    Commented May 3, 2013 at 3:28
  • Follow every single step, to the letter. It WILL identify your issue. Commented May 3, 2013 at 7:18
  • Thanks a lot @sonaasi disabling each module and activating one by one them had helped me finding the bug ... :-)
    – Ravi Soni
    Commented May 3, 2013 at 17:19

You can disable the cache via the command line using MageTool an addon for the Zend Framework command line application.

[ ~ ] $ zf | grep cache
zf clear mage-core-cache tags[=all]
zf flush mage-core-cache
zf enable mage-core-cache tags[=all]
zf disable mage-core-cache tags[=all]

To disable the cache on your site use the following command inside the directory that contains your magento app folder (Magento Root Directory)

zf disable mage-core-cache tags=all

To install the zf cli and the magetool, visit https://github.com/alistairstead/MageTool for more instructions

  • Thanks for this tool actually i disabled the cache from DB.
    – Ravi Soni
    Commented May 3, 2013 at 3:29

If you use disk-based caching you can clear the var/cache/ directory from your Magento root.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.