0

I am new on the Magento 2 platform and working on migrating our shop from Magento 1. I am working on a testmigration and have successfully migrated data and products from M1 to M2 (version 2.3.2).

But i am facing a really confusing problem. When installing extensions, Magento backend does not recognize the extensions as enabled. If i check app/etc/config.php the extension has status 1, enabled and if i run bin/magento module:status the extension has status enabled, but not in Magento admin. The extension is not visible in Stores->Configuration either. I have tried several extensions and the problem is the same. If i try to enable the extension in Magento admin i get this dependency error " Can not find module name. " and in the Module manager list the "module name" field is empty.

To make it even more confusing cache status is not the same in shell as in admin. If i disable cache in shell, cache is still enabled in admin, but if i disable cache in admin it is also disabled in shell.

It seems that Magento admin is not reading changes done in shell. Can anyone help?

Server is running Ubuntu / Nginx / PHP 7.2

All native Magento functions seems to work fine.

EDIT: I have run the following commands in shell:

bin/magento setup:upgrade

bin/magento setup:di:compile

bin/magento indexer:reindex

bin/magento setup:static-content:deploy en_US nb_NO -f

bin/magento cache:flush

I have also deleted the content of /generated/code

My main concern is that Magneto admin/GUI and shell/CLI has different status on cache and module status.

  • First of try to copy your module in default magento 2.3.2 setup and see still are you getting the same error. – Nits Oct 10 at 17:34
  • The problem is not with the extension if that is your thoughts, i have tested several extensions and the issue is the same. Also the cache issue i think point us in a direction of server or magento configuration. – Robert Oct 10 at 18:29
0

You have to run bin/magento setup:upgrade after installing new extensions. Depending on how your cache is setup, you might have to flush the cache bin/magento cache:flush or re-index bin/magento indexer:reindex. I've seen some setups that need all of the static content totally cleared rm -rf /var/www/html/pathtomagento/generated/code/* and re-deployed bin/magento setup:static-content:deploy, followed by cache flushing. I would try each of these while logged out of the admin section, and with that section not open in your browser.

  • None of these options does the trick. I am open to other suggestions. – Robert Oct 10 at 19:13
  • If you use redis, redis-cli flushall, if you use varnish, restart the cache, restart apache. Generally for me, clearing static content and regenerating it works. You could clear all site data from your browser cache as well – Hunter Oct 10 at 20:52
  • Cache is set to local storage now for this testsite and i have deleted cache files. The fact that "bin/magento cache:disable" disables cache in shell/CLI (i have checked status), but not in admin where it is still displayed as enabled is very strange i think. Cache status should not be cached ? – Robert Oct 10 at 21:36
0

Finally i figured out the problem. The inconsistency between CLI and GUI/admin was caused by opcache. When i disable opcache for the magento installation folder Magento admin and frontend shell display the same statuses as shell.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.