I'm trying to run magento 2 with Nginx on Mamp. But I'm always getting error in logs

2021/02/19 12:38:13 [error] 10836#0: *211 upstream sent too big header while reading response header from upstream, client:, server: magento.loc, request: "GET /en_gb HTTP/1.1", upstream: "fastcgi://unix:/Applications/MAMP/Library/logs/fastcgi/nginxFastCGI_php7.3.24.sock:", host: "magento.loc"

enter image description here

enter image description here

I tried to add this params and did nginx reload, it didn't helped. The same error appears. enter image description here

What I can do to resolve it????


1 Answer 1


The buffer size options you have highlighted will resolve this error.

Here is an example MAMP config for Magento https://gist.github.com/apiworks/bbb8ec03843e1926089055d634a2c4db

Check your nginx configuration, in my nginx magento2 site configs (I am not using MAMP) these buffer options are always in the server section.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.