4

I want to add the standard captcha from Magento to our customer registration page. Now I saw that you can enable this captcha in the configuration (System -> Configuration -> Customer Configuration -> CAPTCHA -> Enable Captcha on Front-end). But when I do that and I go to the registration page, there is still no captcha. But when I click on the registration button I get the message:

Incorrect CAPTCHA.

Is there somewhere a tutorial or something? Because I only found it for the contact page and nothing for the registration page.

Thanks for your time.

3

After you configure form for registration the default registration form will be updated with new fields. The preview for the form will be disabled and "Web-form is not available for direct access." will be shown instead - it is done to prevent non-registration submissions.

Configuration parameters

Enable

Enables customization of the default registration form.

Registration web-form

Choose web-form to append to default registration form.

With

"Displaying Mode" set to "Always"

it is showing fine.

  • @TBIInfotech I cant understand what configuration you have mentioned above? Can you please elaborate? I am facing the same issue... – Sanchit Gupta Feb 1 '17 at 12:54
1

I had the same issue, probably you need to go to the system-->configuration-->Advanced and then enable the the Mage_Captcha. I hope it helps

1

New registration CAPTCHA's are in a slightly different area. Go to:

Settings > Configuration > Customers > Customer Configuration:

Turn on: Enable CAPTCHA on Frontend then sort out the configuration to suit your needs i.e. characters used and if case-sensitive etc

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.