I'm having problems getting the 'custompackage' theme I've set up recognised in the Admin panel. I've been able to successfully update the Theme>Default>custom theme but for whatever reason the package name isn't working.

I've followed the steps on the Magento Commerce pages 3 times but have had no luck. The troubleshoot information suggests that maybe i've got the directory wrong, but I'm reasonably confident that I don't - screenshots of where they're saved are below. Is there any other reason this might be happening?

enter image description here

enter image description here

enter image description here

I have also had problems installing Compass - is this possibly causing the problem? (The error I get with this is 'marshal data too short (augment error). - Any help with that also would be greatly appreciated!)


  • what is the name of theme you have enter, by default its "default". And from the picture it show a different theme name. Aug 5, 2014 at 12:20
  • yes, it reverts back to 'default' every time i try to update it to 'custom package' - i was just trying to illustrate what i was trying to do with the image. I've looked into all of the file structures and names and can't find anything wrong with the file folders etc.
    – Frances
    Aug 5, 2014 at 12:31
  • i've also made sure the directory had permissions of 755 so I"m not sure what's causing the issue - any further help would be great! thanks for both of your responses by the way!
    – Frances
    Aug 5, 2014 at 12:32
  • try adding theme from System >> Design. If your theme is readable then it should be available in drop-down list. Aug 5, 2014 at 12:33
  • ok you're right it doesn't appear in the drop down menu - this means it hasn't worked at all? - try again from the start? (would problems with Compass affect this at all?)
    – Frances
    Aug 5, 2014 at 12:35

1 Answer 1


The exception is thrown from Mage_Adminhtml_Model_System_Config_Backend_Design_Package::_beforeSave if the this evaluates to false Mage::getDesign()->designPackageExists($value).

Going deeper in designPackageExists method you will find it returns the evaluation of

is_dir(Mage::getBaseDir('design') . DS . $area . DS . $packageName);

This means it looks for the folder packageName in app/design/{area}.
For some reason it does not recognize your folder.
Check for misspells or read rights.

  • thanks for your feedback, i've looked back through all of the file names and can't see anything wrong with them, or the file structures. You mentioned something about read rights? - permissions? i've just tried to change all permissions to 755 for the magenta directory - will this suffice or do i need to do it for all individual files? (anything else you could suggest I try would be great!)
    – Frances
    Aug 5, 2014 at 12:52
  • You shouldn't give 755 rights to all files and folders. Try t only for your package folder, as a test. Other than investigating why is_dir(Mage::getBaseDir('design') . DS . $area . DS . $packageName); returns false, I have no other idea.
    – Marius
    Aug 5, 2014 at 13:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.