2

I have recently installed a clean installation of Magento 1.7.0.2 on my server. It worked fine with no issues. I then purchased a theme and tried to install it by following the manual, and specifically doing the following:

Disabled Cache - copied theme.zip file (contained 4 folders: apps, js, media, skin with the theme files) to Magento's root folder. Next, I have unzipped the file and merged the folders with the ones installed. I specifically checked that skin and apps folder contain "base", "default" and my theme name (ultimo).

I went to Magento control panel and from there I went to System > Configuration > Design

I filled "ultimo" in Current Package Name and I filled "default" in Themes > Default

I keep on getting the following error: "an error occurred while saving this configuration: package with this name does not exist and cannot be set."

I have asked the author of the theme for help, yet it yielded nothing so far. I have chmoded the permissions of the Magento folder including all the folders therein to 775 and then to 777 - nothing worked and I keep on getting the same message. I tried changing other config settings through Magento's control panel and everything else works fine. My server is fully compatible with Magento and I am run down by trying to install this theme.

I would appreciate anyone's help ... really don't know what to do to solve this issue.

Many thanks

4

Make sure the following folders exist: app/design/frontend/ultimo/default and skin/frontend/ultimo/default
[EDIT]
I actually checked again and only the folder inside app/design is mandatory.
So you only need app/design/frontend/ultimo to exist and be a folder (not a file).
The exception is thrown from Mage_Adminhtml_Model_System_Config_Backend_Design_Package::_beforeSave() and the existence of the package is checked in Mage_Core_Model_Design_Package::designPackageExists()

  • Hi Marius, your answer here doesn't work for me, I have same issue and have tried to debug to get the value of the packageName but it doesn't seem to hinder/halt the execution even if I print like: echo "<pre/>";print_r($value);die; in both the above files you just mentioned. Please help me out here. My magento version is CE 1.9.2.4 – Vicky Dev Apr 13 '16 at 5:56
2

Take care that there is a directory app/design/frontend/default/ultimo and clear the cache.

  • Already tried that... wouldn't ask here if it was the obvious mistake – gizmoron Aug 14 '13 at 4:00
2

I just had the same problem with hellowired theme. I've moved hellowired folder from app/design/frontend/default/hellowired to app/design/frontend/. And it works perfectly.

I also use ultimo theme on other website, and it is in placed in app/design/frontend/ultimo so make sure your ultimo folder is in the right place.

1

If your files are there, make sure they are accessible for magento. This message basically means that they are not. Magento have as much access to the files and folders as the user under which PHP is running.

  • I checked the permissions on the server and chmodded - didn't help – gizmoron Aug 14 '13 at 4:01
0

its simple you have to specify package's name here app/design/frontend/package_name/theme_name. If you paste your theme here app/design/frontend/base/theme_name then you have to specify 'base' as package name. This must be the only problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.