0

I hope you can help me because no solution I find on the internet works.

Change the user's language to Spanish And in the local configuration also to Spanish.

Clean cache but I can not get it to be seen in the Spanish language.

I have tried some solutions (switch to developer mode), re-install the Spanish pack. But it does not work.

7
  • are you trying language es_ES
    – Aman Alam
    Jan 26 '19 at 18:58
  • Yes, I'm trying es_ES
    – Maso
    Jan 26 '19 at 19:08
  • Thats great you can create a folder in your theme i18n and add this file inside github.com/mageplaza/magento-2-spanish-language-pack/blob/… and the run command php bin:magento cache:clean from magento root
    – Aman Alam
    Jan 26 '19 at 19:17
  • also make sure after adding this file run this command to php bin/magento setup:static-content:deploy es_ES
    – Aman Alam
    Jan 26 '19 at 19:24
  • Thanks, I followed the steps and the language is still English. Although in the options I have selected Spanish.
    – Maso
    Jan 26 '19 at 20:32
0

Run below commands and check

php bin/magento setup:static-content:deploy es_ES

php bin/magento cache:flush
0

I have successfully changed the language. I solved it by disabling all types of cache.

1
  • Disabling all types of cache is not really a solution!
    – kanenas
    Nov 12 '19 at 8:04
0

for example we are creating japanese language

firstly download your language pack to magento roor path

then execute the following command

php bin/magento i18n:pack ja_JP.csv ja_JP -m merge -d -vvv

flush & clean cache it will work

check the path: lib/web/i18n/

it should contain your csv file

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.