Magento2 ce 2.2.2 php 7.0.1 3.Mac safari 11.1 and Chrom67.0.3396.87 Explorer Steps to reproduce I had a Magento 2.2.2 with a website that has one store and two store's views (en and tc);

On Stores -> Configuration -> Web, I set "Add Store code to URLs" to "YES" OR "No"(I test)

in default store view(en), I change the language to Chinese, It works first time, Then I change the language to en, It works too;When I change the language to Chinese again, It doesn't work any more;Even if I refresh the page still does not work;

The issue seems to be related to caching, I clear the cache and switch languages, It works again;

Expected result

Language and currency Switcher can switch at any time;

Actual result

Language and currency Switcher are not working at the second time;

ps: I test in phone7 safari and window Chrome, IE 9; It works any time; The issue occurs in Mac Safari and Chrome Explorer;

1 Answer 1


It works after we add the following setting;

Magento Admin -> Store -> Configuration -> Web -> Default Cookie Setting

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.