1

I am working with Magento 2.1.7 and I want to set up a website that will completely display in French.

I did install the community version, 2.1.7 of it and it works well.

But I am trying to change the default language to French and it's a bit hard to do (Two weeks later, It is still not done).

I did change the language to French in Store configuration > General :

  • Country Options
  • Locale Options
  • Site Information

But everything is still in English.

I found a lot of tutorials on that issue. But they all talk about previous versions of Magento 2.x. This one (the 2.1.7) seems a bit different.

Can anybody help me find out How to Change The Default Language To French or another language?

  • You want to change backend or frontend language ? – Feedlay Technologies Aug 6 '17 at 6:09
  • I want to change both of them : Front and Back end. – mosgeorges Aug 7 '17 at 16:25
  • First you have to install language pack for magento2 ,and for admin side you can set from edit user – Feedlay Technologies Aug 7 '17 at 16:28
  • I have try a lot of times to install the language first. But when I copy the french package's key from magento I can see no place to put in on the site. In fact the rutorials that I have seen show a different interface. So that I don't know where to go to install the language package. – mosgeorges Aug 7 '17 at 16:36
  • So can you tell me must I install the package ? – mosgeorges Aug 7 '17 at 16:41
0

For translate you have to install language pack. For that download language pack and put at magentoroot/app/i18n/vendor/fr_fr ref: Magento 2 : How to install new language pack

Change language of frontend : Store > Configuration > General > Locale Options

Change language of backend : System > All Users > Click Any User and change Interface Locale

Then fire below commands:

  • php bin/magento cache:flush
  • php bin/magento setup:upgrade
  • php bin/magento setup:static-content:deploy fr_FR
  • php bin/magento cache:flush
  • After a very long time it did work. Wouah! Such a very hard work. But finally. Thank you so much. – mosgeorges Aug 8 '17 at 16:06
1

This is what you need to do :

  • composer require mageplaza/magento-2-french-language-pack

  • php bin/magento setup:static-content:deploy fr_FR

  • php bin/magento indexer:reindex

  • php bin/magento cache:clean

  • php bin/magento cache:flush

et Voila! Source: https://github.com/mageplaza/magento-2-french-language-pack

  • But it generates an error : – mosgeorges Aug 7 '17 at 15:54
  • Package "mageplaza/magento-2-french-language-pack" listed for update is not installed. Ignoring. Loading composer repositories with package information [Composer\Downloader\TransportException] The "repo.magento.com/packages.json" file could not be downloaded: php_network_getaddresses: getaddrinfo fa iled: H¶te inconnu. failed to open stream: php_network_getaddresses: getaddrinfo failed: H¶te inconnu. – mosgeorges Aug 7 '17 at 16:15
  • This happens when I type the line "composer update mageplaza/magento-2-french-language-pack" – mosgeorges Aug 7 '17 at 16:16
  • I do it on command line. A username and password are been asked to me. I feel them with my admin user and password. Then that error displays... – mosgeorges Aug 7 '17 at 16:17
  • please see my updated answer – elaka Aug 8 '17 at 3:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.