1

I am trying to install an extension for my Magento store. My version of is Magento ver. 2.1.15. Now when i install the extension, it is not visible at Stores->Configuration->Advanced->Advanced

This is the steps i followed to install the extension

 1.Extracted my extension folder into my root            
 2.php bin/magento setup:upgrade
 3.php bin/magento setup:di:compile
 4.php bin/magento cache:clean

But i still cannot find the extension in my store. What could be causing this as i am not seeing any error anywhere ?

PS: I just started working on Magento.

Acl.xml

<?xml version="1.0"?>
<config xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:noNamespaceSchemaLocation="../../../../../lib/internal/Magento/Framework/Acl/etc/acl.xsd">
    <acl>
        <resources>
            <resource id="Magento_Backend::admin">
                <resource id="GlobalSms_Notify::sms" title="GlobalSms" sortOrder="100">
                    <resource id="GlobalSms_Notify::config" title="Config" sortOrder="10" />
                </resource>
                <resource id="Magento_Backend::stores">
                    <resource id="Magento_Backend::stores_settings">
                        <resource id="Magento_Config::config">
                            <resource id="GlobalSms_Notify::sms_config" title="Configuration" />
                        </resource>
                    </resource>
                </resource>
            </resource>
        </resources>
    </acl>
</config>

system.xml

<?xml version="1.0"?>
<config xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:noNamespaceSchemaLocation="../../../../Magento/Config/etc/system_file.xsd">
    <system>
        <tab id="globalsms_notify" sortOrder="2000">
            <label>GlobalSms</label>
        </tab>
        <section id="globalsms_notify_configuration" type="text" sortOrder="10" showInDefault="1" showInWebsite="1" showInStore="1">

            <label>Basic Configuration</label>
            <tab>globalsms_notify</tab>
            <resource>GlobalSms_Notify::sms</resource>
            <group id="basic_configuration" type="text" sortOrder="10" showInDefault="1" showInWebsite="1" showInStore="1">
                <label><![CDATA[Basic Configuration&nbsp;&nbsp;<i>Setting API Account</i>]]></label>
                <field id="notify_username" type="text" sortOrder="10" showInDefault="1" showInWebsite="1" showInStore="1">
                    <label>Enter GlobalSms Username</label>
                    <comment>Enter your GlobalSms SMS API Username</comment>
                    <tooltip>Your username must be the same as your GloablSms api username</tooltip>
                    <validate>required-entry</validate>
                </field>
                <field id="notify_password" type="password" sortOrder="20" showInDefault="1" showInWebsite="1" showInStore="1">
                    <label>Enter GlobalSms Password</label>
                    <comment>Enter your GlobalSms SMS API Password</comment>
                    <tooltip>Your password must be the same as your GlobalSms api password</tooltip>
                    <validate>required-entry</validate>
                </field>
            </group>
        </section>


    </system>
</config>
1
  1. First of all : check if your module has correctly been installed

    Run : php bin/magento module:status and check if your module is present in List of enabled modules:

  2. According to your xml, your module configuration, will be present in :

    Admin > Stores > Configuration > GlobalSms

    and not in :

    Stores->Configuration->Advanced->Advanced

Something like this :

Stores > Configuration >
                       |__ GlobalSms
                               |__ Basic Configuration
                                          |__ Basic Configuration Setting API Account
                                                     |__ Enter GlobalSms Username
                                                     |__ Enter GlobalSms Password

About the installation, you can install extensions by : 1. Adding files to your project via FTP, or 2. via Composer.

| improve this answer | |
  • I check and i am not finding my modules in the list of enabled modules. I installed the extention by just git cloning the folder into my root (magento) – Jonathan Feud Nov 11 '18 at 0:48
  • run php bin/magento setup:upgrade then php bin/magento setup:static-content:deploy -f then php bin/magento c:c – PЯINCƏ Nov 11 '18 at 16:08
0

At first check location of your module it should be at app/code location if you are not installing without composer. After that just just run php bin/magento module:enable VendorName_ModuleName and flush the cache.

Let me know if amy more help needed.

| improve this answer | |
  • I git cloned the module into app/code/Magento and followed the steps in [github.com/aref-lazrek/Sms-Global-Notification-for-Magento-2] but i am still not seeing the extension in my configuration to enable it – Jonathan Feud Nov 11 '18 at 10:30
  • so it means your module location is app/code/Magento/VendorName/ModuleName. If it so then placed it under app/code directly like app/code/VendotName/ModuleName – Ramkishan Suthar Nov 11 '18 at 13:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.