1

I've installed Xampp v.3.2.2 and downloaded Magento CE 2.2.4 & 2.3. but I am facing issue when installing them.

I get the following error::

Fatal error: Uncaught Exception: Warning: "continue" targeting switch is equivalent to "break". Did you mean to use "continue 2"? in D:\xampp2\htdocs\MagentoCE224\vendor\zendframework\zend-stdlib\src\ArrayObject.php on line 426 in D:\xampp2\htdocs\MagentoCE224\vendor\magento\framework\App\ErrorHandler.php:61 Stack trace: #0 D:\xampp2\htdocs\MagentoCE224\vendor\composer\ClassLoader.php(444): Magento\Framework\App\ErrorHandler->handler(2, '"continue" targ...', 'D:\xampp2\htdoc...', 426, Array) #1 D:\xampp2\htdocs\MagentoCE224\vendor\composer\ClassLoader.php(444): include() #2 D:\xampp2\htdocs\MagentoCE224\vendor\composer\ClassLoader.php(322): Composer\Autoload\includeFile('D:\xampp2\htdoc...') #3 [internal function]: Composer\Autoload\ClassLoader->loadClass('Zend\Stdlib\Arr...') #4 D:\xampp2\htdocs\MagentoCE224\vendor\zendframework\zend-stdlib\src\Parameters.php(29): spl_autoload_call('Zend\Stdlib\Arr...') #5 D:\xampp2\htdocs\MagentoCE224\vendor\zendframework\zend-http\src\PhpEnvironment\Request.php(67): Zend\Stdlib in D:\xampp2\htdocs\MagentoCE224\vendor\zendframework\zend-servicemanager\src\ServiceManager.php on line 941

I couldn't find any solution to fix this. Please suggest.

Thanks

2

I'm assuming Xampp v3.2.2 uses php 7.3?

Probably should downgrade php to 7.2 as using continue throws the warning above in the latest php version

https://raw.githubusercontent.com/php/php-src/PHP-7.3/UPGRADING

  • Yes, I have downgrade my xammp version to 1 version back (current Installed version Xampp 7.2.13 / PHP 7.2.13) and issue got resolved. Thanks – Ankush Verma Dec 26 '18 at 12:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.