1

When I'm Trying to upgrade my magento module i'm getting Declaration of Zend\Mvc\Controller\PluginManager Fatal_error

PHP Fatal error: Declaration of Zend\Mvc\Controller\PluginManager::get($name, ?array $options = NULL) must be compatible with Zend\ServiceManager\AbstractPluginManager::get($name, $options = Array, $usePeeringServiceManagers = true) in /var/www/html/Magento/vendor/zendframework/zend-mvc/src/Controller/PluginManager.php on line 211

Help Me to resolve this

0

Generally this error occurs when your PHP Version is Not Supported and Not Compatible with your magento 2 setup.

if you are on linux then run php -v from command line and check which version of php are you using and check that version is supported by magento setup.

Refer this link for supported version of php by magento 2.2 - http://devdocs.magento.com/guides/v2.2/install-gde/system-requirements-tech.html

Also to know more details about the issue refer this link - https://community.magento.com/t5/Installing-Magento-2/Fatal-Error-Installing-on-XXamp/m-p/83571#M3441

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.