0

System set up:

  • Magento 2.2
  • PHP version 7.1.13 fastcgi with Intl installed
  • Ubuntu 16.04.2 LTS‬
  • Plesk version: 17.0.17

Elements to the cron set up

  • magento.cron.log
  • update.cron.log
  • setup.cron.log

Using plesk to schedule cron to the relevant domain on the server

  • magento.cron.log = error
  • update.cron.log = works
  • setup.cron.log = error
  • magento.cron.log = error

PHP Fatal error: Class 'IntlDateFormatter' not found in /vendor/magento/framework/ObjectManager/Factory/AbstractFactory.php on line 111

Some queries suggest removing; from; extension=php_intl.dll

as I cannot directly edit the php.ini (1&1 VPS server) I need to check this will work or any other suggestions?

just to add: setup.cron.log = error. this is without an error notice but I assume that as magento.cron.log is in error it won't work because of that.

  • So i actually managed to remove the ; from ;extension=php_intl.dll but now get this error: <br> [Exception] Notice: Use of undefined constant MCRYPT_BLOWFISH - assumed 'MCRYPT_BLOWFISH' in httpdocs/vendor/magento/framework/Encryption/Encryptor.php on line 397 cron:run [--group GROUP] [--bootstrap BOOTSTRAP] – C1oudM Jan 22 '18 at 16:08
0
  1. Check whether you have mcrypt module or not

php -m | grep mcrypt

  1. If not present, install it

sudo apt-get install php7.0-mcrypt

  1. Enable the module

sudo phpenmod mcrypt

  1. Restart Apache and php-fpm

sudo service apache2 restart

sudo service php-fpm restart

There are chances that it may not work if you have two php installed in the system. One with Apace/php-fpm and one through CLI. In order to be sure that mcrypt is enabled. Creat a file testmcrypt.php in your root and with below code.

<?php
phpinfo();

Run the file your browser and check if you can see the mcrypt module in the page.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.