0

So I have a magento 2 instance running on ubuntu and I have some confusion about cron jobs. I know that magento 2 needs to have scheduled jobs in order to work correctly, but I am unable to find out how to get it set up correctly. I have read the dev docs, and followed this article. Currently, I'm not getting any errors I can see on the magento side, but I'm having issues with things changing correctly (i.e. changing menu options/product options). I have also changed the Missed if Not Run Within field to be longer than the jobs per this The cron_schedule table has all statuses as missed. I am not trying to do any custom jobs, just whatever default ones it needs to operate.

2

Run these commands from your Magento directory:

php bin/magento cron:install

php bin/magento cron:run

and check if all jobs are running by schedule.

  • I haven't ran the install command, Let me try that. How do I check if all jobs running by schedule? Is that an option in the admin side or in the database? Thansk – Morgan Smith Mar 22 at 16:53
  • I ran both these commands, and in the backend of magento all the indexes say on schedule. However, the database is still saying missed. – Morgan Smith Mar 22 at 17:24
1

Any custom extension installed? If not then please truncate Cron tables and check once by running default Magento Cron command.

  • There is a theme, but no extensions. What does truncate the tables mean? Thanks – Morgan Smith Mar 22 at 16:53
  • 1
    Truncate means just flush existing CRON entries. Query: "TRUNCATE cron_schedule" – Jack Mar 27 at 7:18
  • TRUNCATE cron_schedule Yes like this – Jack May 27 at 6:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.