4

I am using a magento 2.1.8 site. I have installed wordpress in a subdirectory of my root directory. I have integrated the wordpress and magento site by using fishpig wordpress extension. All other things are working fine. Now I got all my wordpress post in this url www.example.com/blog

The issue is I have assigned few categories to a post, For example,blog,category1,category2,category3 etc.

When I take the post in browser, it shows the url as www.example.com/blog/blog/posturl/.

I want the post url as www.example.com/blog/category2/posturl/.

How can I do it? When ?I tried the permalinks extension in wordpress,but still the issue exist.

1

Try settings same as following example:

1. Set your WordPress setup folder name "wp".

2. M2 Admin Menu > WordPress > Path = wp

3. Database: magento2_wp > Table: wp_options

option_id = 1
option_name = siteurl
option_value = http://www.example.com/wp //Folder name of your WordPress installation.
autoupload = yes

option_id = 2
option_name = home
option_value = http://www.example.com/blog //Frontend URL
autoupload = yes

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.