0

I am using a magento 2.2.5 site. I have installed WordPress in a sub directory of my root directory. I have integrated the WordPress 5.2.4 in magento site by using fishpig WordPress extension. All other things are working fine. Now I got all my WordPress post in this url www.example.com/blog

The issue is i tried saving post in WordPress admin but it reflects error as below api-fetch.min.js?ver=3.1.2:1 POST hwww.example.com/blog/wp-json/wp/v2/posts/6978?_locale=user 404 (Not Found).

How can I do it? When ?

I tried the permalinks extension in WordPress,but still the issue exist.

2
  • Try saving permalinks in admin general settings. Also i feel its .htacccess permission issue by Magento. you need to do some tweak with this. Nov 6 '19 at 5:20
  • Tried saving permalinks but not working Can u provide detail regarding .htaccess file how to provide permission
    – Unknown
    Nov 6 '19 at 5:47
1

Install wp-cli in your wordpress site

Update the url in this way :

wp option update home https://yoursitename.com/blog/
wp option update siteurl https://yoursitename.com/wp/

wp cache flush
wp option get siteurl
wp option get home
  • Check if you have any iframe integrated in your post.
  • Try to remove the iframe and save the post again. If you want the iframe , you should give permissions on firewall .
1
  • 1
    I had no idea about this tool. Great tip! Nov 6 '19 at 21:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.