1

I'm working in the wamp server in window 10 and run the setup:di:compile in the shell then the site is display blank.

i also try this method - magento 2 not working after the command bin/magento setup:di:compile.

but that also not worked for me.

  • Do you get any errors when you inspect the source or in var/log? – Koen Feb 7 '18 at 12:02
0

First delete below folders : go to root directory

pub\static

var\cache

var\page_cache

var\view_preprocessed

var\generation

Now run below commands

php bin/magento setup:static-content:deploy

php bin/magento indexer:reindex

now check it will work !!

  • I tried this method but the result is the same i still got the blank white page................. – govindaraj Jan 8 '18 at 5:33
0

static-content:deploy doesnt run without --force, my opinion is that 2.2.2 is not usable, when installing custom plugins, the admin backend doesn't show any changes until scheduler was run, some plugisn doesnt work in general, compose installation is not working, composer.json is not updated, instead data is written to composer.lock, setup:upgrade shows "nothing to install" but modules where added ..., sometimes you have to restart apache to get changes shown == default caching is not working correctly, etc...

0

I have same issue on 2.2.3 When I remove folder generated/ on webroot it works (2.2 magento have moved var/generated to webroot)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.