0

I ran below Command:

bin/magento setup:di:compile

I have tried to upgrade my module with:

$ php bin/magento setup:upgrade

The end result was:

Please re-run Magento compile command

After doing this magento site is not working.

2

Please go to app\bootstrap.php

Do comment below line

error_reporting(E_ALL);
#ini_set('display_errors', 1);

& check for error in browser or check log files under var/log or var/report folders

Try to run below commands as well

php bin/magento cache:clean
php bin/magento cache:flush
  • Good to hear that :) – Ankit Shah Oct 4 '16 at 9:51
  • after running the compile command, the page is blank, I clear & flush the cache after running the compile command but still, it's blank, if I run the setup: upgrade & content-deploy then only the page is loading well. – senthil Oct 26 '18 at 7:53
2

Try to Run the Below Commands which will clear the Cache :

php bin/magento cache:flush
php bin/magento cache:clean

Still Error there then paste exact error here

cd <your magento root>
rm -Rf var/generation 
  • after running these command when i hit my page(localhost/magento2) i got "An error has happened during application run. See exception log for details". – praveen cruz Oct 4 '16 at 9:38
  • please check your exception log file & paste error – Brad Hodge Oct 4 '16 at 9:38
  • where to find the exception log – praveen cruz Oct 4 '16 at 9:39
  • you can find under : var/log – Brad Hodge Oct 4 '16 at 9:42
  • i updated my answer please try last command – Brad Hodge Oct 4 '16 at 9:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.