0

I am using magento 1.9 version for my site. I have installed SSL coupe of days back after that customer are not able to to login to my website.

I followed this solutions

Can't log into Secure (SSL) Magento site on front end in Chrome

magento 1.9 customer can not login

Customer Login Doesn't Work in 1.9

but still customer can not able to login to the site.

0

Make sure to clear cache and try another browser.

  • yes i have cleared cache more time and try another browser but still not working. If I change Secure Base URL https to http, then login working – Kanhu Charan Rath Jun 8 '17 at 10:49
0

Change your secure url to https under core_config_data.

  • httpa. Are you saying https? – Kanhu Charan Rath Jun 8 '17 at 9:30
  • yes https please, sorry for mistake – Ledian Hymetllari Jun 8 '17 at 10:04
  • I have already put this but still not working. Can i get any other solution? – Kanhu Charan Rath Jun 8 '17 at 10:31
0

Change secure and unsecure base url of your magento store from -

Admin Panel -> system-> configuration -> Genral-> Web

and change Secure and unsecure url http:// to https://

And Make Sure you have form_key input on your register.phtml

  • I have changed this section but still not working – Kanhu Charan Rath Jun 8 '17 at 12:08
0

You have to force Magento to use the same cookie domain for both secure and unsecure URLs. You can inspect your sites cookies using the developer tools in the FireFox or chrome browser. This solution was tested on Magento 1.9.2.4

When the Session Cookie Management variables are not set incorrectly Magento may create two "frontend" cookies with different cookie domains. This typically happens during the login process when you have HTTPS (ie. SSL enabled) for the secure URL. Here are workable values for the Session cookie management configuration.

Cookie Life Time: 3600
Cookie Path: /
Cookie Domain : .mydomain.com (The dot prefix is important)
Use HTTP Only : No
Cookie Restriction Mode: No 
  1. In the admin panel go to System -> Configuration -> Web-> Session Cookie Management
  2. Set the Cookie Management configuration as shown above
  3. Save the configuration and clear the Magento cache
  4. Restart your web server to clear the PHP variables in case you made the change directly in MYSQL database
  5. Clear your browser cache to remove any existing cookies associated with your magento site.

Using the dot prefix on the cookie domain is important to prevent duplicate cookies from being created for the secure URL

Changing the cookie domain will also affect the "adminhtml" cookie used by the Magento back end. Make sure to clear your browser cache to prevent admin login problems.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.