1

When trying to download the patch SUPEE 5344 for CE 1.7.x from https://www.magentocommerce.com/download the patch has a header which seems to say it's a patch for EE 1.12.

SUPEE-5345 | EE_1.12.0.2 | v1 | 2d36f61cf684ed26286b6d10307fcb99dd47ff02 | Thu Feb 5 19:39:01 2015 +0200 | v1.12.0.2..HEAD

Is this is a mistake on the behalf of Magento, and where can I find the patch for CE?

Update: To make clear, this is not a problem with the filename of the patch, I'm aware SUPEE-5344 changes to 5345 when downloading for CE 1.7.x, the problem comes when you open the file and see the file is intended for Magento EE 1.12

  • Interesting, i just downloaded the SUPEE-5344 patch for 1.7. (select SUPEE-5344 - Magento-CE-v1.7.x (0.01 MB)) from the list and the file name is PATCH_SUPEE-5345_CE_1.7.0.2_v1-2015-02-10-08-11-22.sh – Anna Völkl Aug 30 '16 at 10:58
  • Actually the filenames should be named according to their version (either CE or EE) – Anna Völkl Aug 30 '16 at 10:59
  • Sorry, I should have made clear, the filename is indeed correct (PATCH_SUPEE-5345_CE_1.7.0.2_v1-2015-02-10-08-11-22.sh), the patch SUPEE-5344 changes the last number depending on which version you download it for. This is a known 'issue' and hasn't caused problems in the past. If you open the file you'll see the header reads 'EE_1.12.0.02' which implies the file is for the Enterprise Edition – jb492 Aug 30 '16 at 11:59
1

If the lines after this header are

__PATCHFILE_FOLLOWS__
diff --git app/code/core/Enterprise/Logging/Block/Adminhtml/Grid/Filter/Ip.php app/code/core/Enterprise/Logging/Block/Adminhtml/Grid/Filter/Ip.php

Then you actually have the patch for EE 1.12.

If not, Magento just copied the EE patch file, removed the enterprise specific changes and forgot to update the header.

  • This would be a very interesting issue especially since this was the shoplift patch, no? – philwinkle Aug 30 '16 at 12:23
  • I have checked and you're right, there are no changes to the Enterprise folder in the patch. This solves it, I have the CE patch but Magento simply forgot to update the header. – jb492 Aug 30 '16 at 12:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.