I am developing a custom payment module and I am trying to show it on the product checkout page, without success. The thing is that not a single payment method (even the default ones) is shown at the checkout page, even when my payment module is disabled. The payment methods are enabled on admin panel.
How do I enable any payment method (beside admin panel), or how do I debug the whole process?

Update 1

I installed magento-sample-module, Braintree and Inchoo_Stripe method payment.
How can I enable at least Cash On Delivery Payment as a payment method?

Update 2
I went debugging. I installed wireshark and received the folowing (part of) response from server: {"payment_methods":[{"code":"cashondelivery","title":"Cash On Delivery"}],"totals":.... It appears that a propper response is received, but the JSON processing fails. I will come with another update soon.

  • You're trying to create an offline payment? Commented Aug 26, 2016 at 14:06
  • 2
    Maybe this answer will be helpful for you. Also add code for your question to understand your problem.
    – joni jones
    Commented Aug 26, 2016 at 15:54
  • There is not a problem with my code, since my module is disabled. The thing is that not a single payment method is shown in checkout page, although the methods are enabled in admin pannel. I checked the your answer and it didn't made any difference.
    – Ivy
    Commented Aug 27, 2016 at 9:40

2 Answers 2


Can you try disabling all the custom payment method extensions and custom checkout extensions. Also check Magento log file for the error.

  • I did try it. I disabled all the payment methods, the merchant country is Romania, the shipping method is Free shipping. At checkout: No Payment method available.. I enabled the Cash on delivery payment. Reload the checkout steps and no change. I also work in developer mode, so the cache is invalidated every time.
    – Ivy
    Commented Aug 29, 2016 at 15:42
  • I am talking about the custom payment method extensions and not the default payment methods. And also If you have used custom checkout, disable it. Try to upload default checkout file of Magento related to your current version.
    – user41152
    Commented Sep 3, 2016 at 4:41

The solution was simple: the file in the Theme\Magento_Checkout\layout\checkout_index_index.xml (copied from Luma theme) was wrong, thus making the error above. The solution was simple: I deleted the file and let the app\code\Magento\Checkout\layout\checkout_index_index.xml take the page.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.