4

So I recently installed Ubuntu 16.04 on an old laptop.

Running PHP 7:

PHP 7.0.4-7ubuntu2.1 (cli) ( NTS )
Copyright (c) 1997-2016 The PHP Group
Zend Engine v3.0.0, Copyright (c) 1998-2016 Zend Technologies
    with Zend OPcache v7.0.6-dev, Copyright (c) 1999-2016, by Zend Technologies
    with Xdebug v2.4.0, Copyright (c) 2002-2016, by Derick Rethans

I'm trying to install Magento 2.0.7 but my installation is stuck at 65%

enter image description here

I've increased the memory allocated to PHP to 768M as suggested by the official doc but still stuck.

There's nothing in the Magento logs, nothing in the apache error logs.

In the firebug console tab, I can see that there are POST calls every few seconds to /setup/index.php/install/progress where the response is always the same and represents the progress listed in the console log.

There's also a POST call to /setup/index.php/session/prolong from time to time where the response is always:

{"success":false}

I don't usually post that kind of installation questions but to be honest, I'm running out of ideas regarding what it could be.

Let's assume I don't have access to command line and I absolutely want to install via the web setup wizard. I want to know what is causing this issue and how to fix it

  • 1
    I am also facing same issue with Ubuntu 14.04 . Magento 2.0.7 for several times ends up 89%. – Krishna ijjada Jun 6 '16 at 17:06
  • 2
    If its not progress you should stop process and try to run php bin/magento setup:upgrade this will install rest of the module. Or if UI is not working you should try to install with command line with php bin/magento setup:install --base-url=http://127.0.0.1/magento2/ \ --db-host=localhost --db-name=magento --db-user=magento --db-password=magento \ --admin-firstname=Magento --admin-lastname=User --admin-email=user@example.com \ --admin-user=admin --admin-password=admin123 --language=en_US \ --currency=USD --timezone=America/Chicago --use-rewrites=1 – Aman Alam Jun 6 '16 at 17:10
  • 2
    is rewrite_module enabled? – Nickool Jun 6 '16 at 17:14
  • @aman_uni yeah I've installed M2 several times before and used the command line in the past but – Raphael at Digital Pianism Jun 6 '16 at 17:14
10

Thanks to @Nickool, I found out apache mod_rewrite was not enabled.

So I ran:

sudo a2enmod rewrite

Added the following lines to my /etc/apache2/sites-available/my.host.com

    <Directory /var/www/html/m2>
            Options Indexes FollowSymLinks MultiViews
            AllowOverride All
            Order allow,deny
            allow from all
    </Directory>

Then ran:

sudo service apache2 restart

And now the installation is finishing.

The mod_rewrite requirement is stated here: http://devdocs.magento.com/guides/v2.0/install-gde/system-requirements.html

But not here: http://devdocs.magento.com/guides/v2.0/install-gde/prereq/apache.html

I reckon the doc needs a small update

  • cool! since it happened to me once :) – Nickool Jun 6 '16 at 18:05
  • @raphael-at-digital-pianism open a PR for the docs then. The documentation team is extremely responsive, and open to receiving assistance from the community. An opportunity that shouldn't be missed! ;). – ryanF Jun 8 '16 at 6:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.