13

I have installed Composer and followed the steps to install Magento2. It will be stuck at 93%. It isn't giving any proper error...

Please check the image:

enter image description here

Also, it will display in configuration, as below image.

enter image description here

We got an error in:

"Installing user configuration."

Is someone facing same issue? If so, how did you resolve this issue?

3 Answers 3

14

Just put this code in your .htaccess file

<IfModule mod_php5.c>
  php_value  xdebug.max_nesting_level 500
</IfModule>

This is known issue with xdebug Issue with xdebug

Further you can check here https://blog.amasty.com/magento-2-installation-guide/

5
  • Grt Its Working.
    – Keyul Shah
    Commented Dec 19, 2014 at 13:15
  • hi I got Success Page But getting this Message An error has happened during application run. See debug log for details.
    – Keyul Shah
    Commented Dec 19, 2014 at 13:19
  • Have your installation working properly?
    – Mufaddal
    Commented Dec 19, 2014 at 13:20
  • yes I checked log Its cookie Problem in log
    – Keyul Shah
    Commented Dec 19, 2014 at 13:21
  • hey I have some problem I have clone the repo but magento2\pub\static whole folders are missing
    – Keyul Shah
    Commented Dec 19, 2014 at 13:32
8

Following Solution work for me.

In php.ini put following setting

xdebug.max_nesting_level = 200;

Or If it not work then you can put the following code in top of setup/index.php

ini_set('xdebug.max_nesting_level', 200)
5
  • Ok grate I will check this one also
    – Keyul Shah
    Commented Dec 22, 2014 at 8:27
  • 1
    Try it .. this solution is also available on gist.github.com/wsakaren/a1488ebfd2a75317e94e I don't know why i am receiving minus points Commented Dec 22, 2014 at 8:32
  • 2
    i give u +1 vote
    – Amit Bera
    Commented Dec 22, 2014 at 8:47
  • @Frontmage probably because your answer was published two days after the accepted answer with the same solution.
    – user2857
    Commented Dec 22, 2014 at 12:00
  • 2
    @ADM Yes i know it is same answer but different way. Because i have solved with this way. We can list out multiple solution to same problem. Commented Dec 23, 2014 at 4:48
1

You should change the 'vendor' directory permission to 0777. I got same error and resolved after updating permission...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.