0

Trying to install Magento 2.3 locally (Nginx-Php 7.1-Mysql- Centos 7), but it stucks on installation progress at 0% . Console error log says : http://domain.test/setup/index.php/install/start 500 Internal server error.

Is it an nginx configuration or magento file permission issue, or something else?

4
  • 1
    check exception log, php error log and update the answer
    – Sohel Rana
    Commented May 13, 2019 at 14:39
  • read error log nginx/php/magento
    – MagenX
    Commented May 13, 2019 at 21:11
  • No logs found in exception.log, nignx, php or system log saying anything about this issue Commented May 14, 2019 at 6:43
  • Some time may occur just refresh Page and issue may resolve. Commented Oct 8, 2019 at 9:21

7 Answers 7

0

Could be not enough memory.

Check this

https://devdocs.magento.com/guides/v2.3/install-gde/trouble/php/tshoot_php-set.html

1
  • Gave memory_limit = 10000M in php.ini . Still same issue Commented May 14, 2019 at 6:44
0

Are all the required php extensions installed?

https://devdocs.magento.com/guides/v2.3/install-gde/system-requirements-tech.html

Try the php module part of this https://github.com/sjanjic/magento2-check?files=1

check.php

<?php
error_reporting(E_ALL);
ini_set('display_errors', 1);

function result($value, $result)
{
    if ($result) {
        return array('css' => 'success', 'note' => $value . ': OK');
    }
    return array('css' => 'danger', 'note' => $value . ': FAIL');
}

function apacheModules()
{
    $results = array();
    preg_match('/([\d]+\.[\d]+\.[\d]+)/', apache_get_version(), $version);
    $results[0] = array('css' => 'danger', 'note' => 'Version: ' . $version[0]);
    if (version_compare($version[0], '2.2') >= 0) {
        $results[0] = array('css' => 'success', 'note' => 'Version: ' . $version[0]);
    }
    $requiredModules = array('mod_rewrite','mod_expires');
    $apacheModules = apache_get_modules();
    foreach ($requiredModules as $req) {
        $results[] = result($req, in_array($req, $apacheModules));
    }
    return $results;
}

function phpExtensions()
{
    $results = array();
    preg_match('/([\d]+\.[\d]+\.[\d]+)/', phpversion(), $version);
    $ver = $version[0];
    $results[0] = array('css' => 'danger', 'note' => 'Version: ' . $ver);
    if ((version_compare($ver, '5.6.5', '>=') && version_compare($ver, '7.0.0', '<')) || version_compare($ver, '7.0.2',
            '==') || version_compare($ver, '7.0.4', '==') || version_compare($ver, '7.0.6', '>=')
    ) {
        $results[0] = array('css' => 'success', 'note' => 'Version: ' . $ver);
    }
    $requiredExtensions = array(
        'curl',
        'gd',
        'intl',
        'mbstring',
        'mcrypt',
        'openssl',
        'PDO',
        'SimpleXML',
        'soap',
        'xml',
        'xsl',
        'zip',
        'json',
        'iconv',
        'Zend OPcache',
        'xdebug',
    );
    $phpExtensions = get_loaded_extensions();
    foreach ($requiredExtensions as $req) {
        $results[] = result($req, in_array($req, $phpExtensions));
    }
    return $results;
}

function phpOptionalExtensions()
{
    $optionalExtensions = array(
        'imagick',
    );
    $phpExtensions = get_loaded_extensions();
    $results = array();
    foreach ($optionalExtensions as $opt) {
        $results[] = result($opt, in_array($opt, $phpExtensions));
    }
    return $results;
}
//apacheModules();
?>
<!DOCTYPE html>
<html>
<head>
    <!-- Latest compiled and minified CSS -->
    <link rel="stylesheet" href="https://maxcdn.bootstrapcdn.com/bootstrap/3.3.7/css/bootstrap.min.css"
          integrity="sha384-BVYiiSIFeK1dGmJRAkycuHAHRg32OmUcww7on3RYdg4Va+PmSTsz/K68vbdEjh4u" crossorigin="anonymous">
    <!-- Optional theme -->
    <link rel="stylesheet" href="https://maxcdn.bootstrapcdn.com/bootstrap/3.3.7/css/bootstrap-theme.min.css"
          integrity="sha384-rHyoN1iRsVXV4nD0JutlnGaslCJuC7uwjduW9SVrLvRYooPp2bWYgmgJQIXwl/Sp" crossorigin="anonymous">
    <!-- Latest compiled and minified JavaScript -->
    <script src="https://maxcdn.bootstrapcdn.com/bootstrap/3.3.7/js/bootstrap.min.js"
            integrity="sha384-Tc5IQib027qvyjSMfHjOMaLkfuWVxZxUPnCJA7l2mCWNIpG9mGCD8wGNIcPD7Txa"
            crossorigin="anonymous"></script>
</head>
<body>
<div class="container">
    <h1>Magento 2 requirements check script</h1>
    <div class="panel panel-default">
        <div class="panel-heading">Apache</div>
        <div class="panel-body">
            <?php foreach (apacheModules() as $result): ?>
                <div class="alert alert-<?php echo $result['css'] ?>" role="alert"><?php echo $result['note'] ?></div>
            <?php endforeach; ?>
        </div>
    </div>
    <div class="panel panel-default">
        <div class="panel-heading">PHP</div>
        <div class="panel-body">
            <div role="alert" class="alert alert-warning">Loaded php.ini file: <?php echo php_ini_loaded_file()?></div>
            <?php foreach (phpExtensions() as $result): ?>
                <div class="alert alert-<?php echo $result['css'] ?>" role="alert"><?php echo $result['note'] ?></div>
            <?php endforeach; ?>
        </div>
    </div>
    <div class="panel panel-default">
        <div class="panel-heading">Optional PHP Extension</div>
        <div class="panel-body">
            <?php foreach (phpOptionalExtensions() as $result): ?>
                <div class="alert alert-<?php echo $result['css'] ?>" role="alert"><?php echo $result['note'] ?></div>
            <?php endforeach; ?>
        </div>
    </div>
</div>
</body>
</html>
0

I've just leant that Xdebug enabled can stop installation process

https://devdocs.magento.com/guides/v2.3/install-gde/trouble/tshoot_install-issues.html

0

try to setup magento using ssh command:-

php bin/magento setup:install --base-url=http://127.0.0.1/magento2/ --db-host=localhost --db-name=magento --db-user=magento --db-password=magento --admin-firstname=Magento --admin-lastname=User [email protected] --admin-user=admin --admin-password=admin123 --language=en_US --currency=USD --timezone=America/Chicago --use-rewrites=1

hope it will help you.

3
  • SQLSTATE[HY000] [1045] Access denied for user 'root'@'localhost' (using password: YES) , even though i give the correct credentials. I changed my root password in mysql but i still get the same error Commented May 14, 2019 at 8:34
  • have you created same db? Commented May 14, 2019 at 8:38
  • yes. i created same db(same name) Commented May 14, 2019 at 8:57
0

It was an php configuration issue. Because i'm working locally with vagrant i had to change my user and group in /etc/php-fpm/www.conf file from nginx to vagrant.

0

Delete all files in the pub/static directory except the .htaccess file.

Then modify two files:

vendor/magento/framework/Filesystem/DriverInterface.php line 20

const WRITEABLE_DIRECTORY_MODE = 0755;

line 25

const WRITEABLE_FILE_MODE = 0644;

to make it temporarily set 0755 0644 permissions.

Then refresh magento cache.

-1

Looks like file permission issue, try to install it with 777 permission first.

login to to ssh then:

sudo chmod -R 777 magento_root_directory

As 777 is not correct permission not secured, you can just test installation with it, after this you will have to provide correct permission to all file and folders, please refer below:

https://devdocs.magento.com/guides/v2.3/install-gde/prereq/file-sys-perms-over.html https://magehit.com/blog/magento-2-file-folder-permissions-setting/

2
  • Changed my project files and folders permissions to 777. Problem still remains. domain.test/setup/index.php/install/start 500 (Internal Server Error) Commented May 14, 2019 at 6:46
  • is php files running on your server? try to run info.php , enable error reporting, add this into your index.php file. error_reporting(-1); ini_set('display_errors', 'On');
    – Saphal Jha
    Commented May 14, 2019 at 7:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.