I'm using Magento

I have a store in English, I want to have the same store (same categories and products) just translated to Spanish.

I used this tutorial to achive this: Ref.

I created another store view in my store. Under System->Configuration->General->General->Locale Options->Locale for the Spanish store view, I un-checked the "Use Website" and selected "Spanish".

Under Catalog->Manage Categories I changed the store view to Spanish and I translated the Name of each category to Spanish.

Under Catalog->Manage Products I changed the store view to Spanish and I translated the Name of each product to Spanish.

Now, In the frontend, when I switched the the Spanish store view (using the language switcher), I can see my store in Spanish, including the categories and products.

But when I add a product (that I can see in Spanish in the category page) to the shopping cart and goes to the shopping cart, I can see the product, but is name is in English (although I'm in the Spanish store view). Also under Order Review in the Checkout page it's in English.

What can be the problem? How can I fix it?


EDIT: I upgraded my store to and it doesn't help.

  • Might be some problem with the theme you are using. Have you checked falling back to the base Magento theme ?
    – Prateek
    Feb 3, 2016 at 10:49
  • I changed the package for the Spanish store view to "default". The theme has changed, but the products name in the shopping cart is still in English.
    – Nir
    Feb 3, 2016 at 10:57
  • Must be a problem with one of your extensions then, which changes how products are converted to quote items. Try to disable them one after each other using the files in app/etc/modules to find out which one. Feb 4, 2016 at 22:17

1 Answer 1


Are you using any module for checkout which is extending layout ?
There might be the scenario that any module is extending the product collection in cart and not reading based on selected store view.
Default Magento view will have localized attribute value only and as you say product name is in Spanish in all other pages then check your installed modules.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.