2

I have been puzzled for more then a week and I really hope someone can help.

Situation is that we have nm online store that works great wine online store So far so good after testing all and going online I deleted dev site. Some 3 weeks ago after running for some 6 months, out of the blue some funny started to go wrong, if I clear cache or try to deactivate compiler, the site goes down and front end appears without header.

So now I have copy entire site to development site. And strait from start it give front end without header I mean <head></head> appears empty.

I have tried about everything, clean install, new .htaccess, new php.ini. getting rid of all extentions, desactivating all static blocks, deleting core/local and reading hundreds of forums and nothing I just get this empty head.

PS: running on a dedicated linux server and consulted server senior admin aswell.

  • Today I narrowed this issue by refreshing just the Configuración > System(config.xml, local.xml) and modules configuration files(config.xml) from cache management and it seems to be the one that causes the <head> tag to get empty. Could this be of help to figure out what is going on? – Daniel D Oct 14 '13 at 16:01
1

One thing that occasionally gets us is our third party caching service. In addition to the standard Magento caches we run memcached. Gave me headaches trying to figure it all out until I realized that memcached still was serving up old files.

  • to my knowledge we are not using memcache...the issue is that when I clear var entirelly (or flush cache from admin) i get empty head tag, I have even tried to edit with chrome developer´s tool and add the content to head tag and all works fine.. but of course that is another story. – Daniel D Oct 12 '13 at 15:33
  • anyone has encounter this issue, it is really annoying to the point that I may have to rebuild the entire store from scratch, i would really appreciate some help. – Daniel D Oct 12 '13 at 18:56
1

I guess nobody has got a clue on this issue, and after testing and trying all kind of solutions, I decided to reinstall on dev server and my guess is that this was related to some database error, but it is just a guess.

I recovered everything and now I can clear cache with no issues.

Thank you MustacheMcLimey for replying, even if the issue wasn't related to memcache, i really appreciate your reply.

Cheers Daniel

1

I had the same problem where <head> was empty and it turned out to be Full Page Cache (FPC) <cache> settings in the local.xml while the module was disabled. Enabeling the module didn't solve the problem either so we just removed the cache settings for now and it worked again. We have to do more research into why that broke down in the first place.

Hope it helps others that get this problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.