0

I setup a magento store that is in production since a year and half with no issue except this one : For performance reason i put /var/www/html/var/cache and /var/www/html/var/session in a ramdisk using the following code

tmpfs -o size=128m /var/www/html/var/cache tmpfs defaults,uid=apache,gid=apache,mode=755 0 0
tmpfs -o size=128m /var/www/html/var/session tmpfs defaults,uid=apache,gid=apache,mode=755 0 0

With apc and this setup the store is fast enough for us small target.

The problem i have with this setup is following : when i create a new categorie (menu or not), they appear frontend only if cache is dissable in Magento. If i enable again the cache the new categorie dissapear again.

This happen even if i flush the cache before from admin, (the both folder i could watch from fizella become empty) or using *rm -rdf /var/www/html/var/cache/* in command line

If i reboot the server, everything will work fine i could enable the cache in the admin and the the new categorie create front end. I have a similar issue with the home slider. Except that the store works as normal, new product appear normally frontend with this setup.

If i dissable the ramdisk everything work totally normal, i could create new categorie and they appear immediatly frontend

Seems there is some persistent file in ramdisk even if i flush the cache from admin or using *rm -rdf /var/www/html/var/cache/*

Any idea how totally flush the cache of tmpfs ramdisk partition ? seems there is some persitent cache file in it, until reboot Ramdisk really boost the store on a small server without ssd, so i will be happy to keep it.

0

I finaly found how to solve the issue :

tmpfs -o size=128m /var/www/html/var/cache tmpfs defaults,uid=apache,gid=apache,mode=755 0 0

The defaults options = rw, suid, dev, exec, auto, nouser, and async I just removed it, no sure wich option removed make the trick but now its works (i was thinking async / sync, thats its not ideal but the server perform as before) I could now create new menu,slider and i just have to clear cache from admin. No more reboot and happy Thanks

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.