0

My project had an extension called webshopapps product matrix

Which was copied from another project and had been configured . But now when I replace it with the new extension by placing its files and folders in its place, it shows error as :

"An error occurred while saving this configuration: Invalid Product Matrix File Format Array"

in the admin section while importing a csv file.
What should I do ?

3
  • Have you tried contacting the developer of this extension?
    – Badger
    Dec 9, 2015 at 8:46
  • What do you mean with "new extension"? Did you purchase an updated version? Then contact Webshopapps support. They are nice and helpful as long as you don't pirate their stuff. Dec 14, 2015 at 8:51
  • yes, @fschmengler. I have to consult with the support team of webshopapps.Thanks. Dec 14, 2015 at 11:35

2 Answers 2

0

Export a .csv file from your extension and see how you should build the .csv file you want to import. Copy the format.

0

Have you resolved this issue? I experienced similar issue so I figured I would share what worked for me.

If you search the extension code for the exception message "Invalid ProductMatrix File Format", you'll see above the exception you should have the following condition:

if ($csvCount < 13 || $csvCount > 17....

In my case, I had 17 columns, one was not default to the extension. I removed that column giving me a total of 16, imported the sheet successfully. Hope that helps!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.