1

I am trying to enable the authorize.net direct post payment method. After filling in the fields, and clicking the save config button, the admin freezes and becomes unresponsive for a few seconds to a minute. I have also gotten a fatal error: exceeded allocated memory php message a time or two. Any ideas as to what's happening here. There are now errors reported in any of the logs and no console errors either. Thanks for your help.

  • You may want to disable the local codepool via app/etc/local.xml and also disabling community modules to determine if its a 3rd party module causing the freeze. Normally this shouldn't occur in an out of box Magento install. For further debugging info: magento.stackexchange.com/questions/428/… – B00MER Nov 18 '15 at 4:30
  • thanks boomer however your instructions flew right over my head. I am new to magento and don't know how to implement your ideas. Also, I did tweak a couple of things and now from the frontend, on submitting an order, I am getting a "Error, check your md5 settings". I have double checked the values on AN but it seems as though the values aren't saving in the Mage backend, This is possible related to the freezing situation? Can you point me towards more detailed directions? – alan-ch Nov 18 '15 at 19:10
  • From the sounds of the error you're receiving, some portion of the code base is causing a large chunk of memory to be allocated, hence the reason for the fatal error. This isn't normal functionality for Magento out-of-box features, and hence my suspect of a 3rd party module being the root of the problem. Is the module you are using for authorize.net a 3rd party? – B00MER Nov 18 '15 at 23:45
  • I am not using any third party extensions. My magento is straight out of the box. The only exception would be my custom theme but there is nothing but css and layouts... nothing that I would think would be conflicting or affecting the payment method or module. Perhaps I should reinstall? – alan-ch Nov 19 '15 at 1:34
  • You may find some info in var/logs/system.log and var/logs/exception.log also looking at the contents of files in var/report/ Also web server logs may offer some insight as well. You may also want to try a different payment method for testing just to see if that is related to the authorize.net module. I don't think reinstalling would help, it may be a server related issue, so contacting your host may offer some insight as well. good luck. – B00MER Nov 19 '15 at 3:06
0

I changed the Current Configuration Scope to be the second one under Default. After doing this, I was able to deselect the Use Default checkbox to the right hand side of each setting item that I wanted to change. Save Config then worked.

| improve this answer | |
  • Thanks Tania. This is old but I wanted to accept your answer as it solved my issue, though I came upon it on my own. It seems that the scope setting was causing the failure. Thanks again. – alan-ch Mar 27 '16 at 15:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.