0

I have being trying to use Authorize.net as a payment method for magento 1.9 site. The checkout page works great if I have paypal enabled. As soon as I change to Authroize.net the checkout page shows the No Payment Methods error.

With Paypal I can see the payment method at the checkout page, with Authorize.net the message No Payment Methods shows.

I have verified:

UPDATE: I have found that we are using RicoNeitzel/PaymentFilter!!!

Any help on this matter will be greatly appreciated.

  • let's start with the basics...have you cleared cache? is auth.net enabled for the correct storeview? are you sure the Auth.net API credentials are correct? is the transaction key correct (try generating a new one)? if TestMode=YES, are you using the sandbox urls + sandbox credentials? do you have any payment-restriction extensions installed? – kmdsax Jan 24 '18 at 16:23
  • The cache has been cleared. The credentials are correct. I have no payment-restrictions extensions installed. Will be trying generating a new transaction key. And also will try to test the sandbox credentials. – ctorresr Jan 24 '18 at 16:33
  • Also, check your var/log/exception.log and var/log/system.log files for any clues. – Olivier Jan 24 '18 at 16:45
  • Created new Authroize.net credentials, I'm using live credentials. Still not showing up. Or any errors on system.log exception.log – ctorresr Jan 24 '18 at 18:00
0

My problem was that we are using riconeitzel-paymentfilter extension. This will filter payment methods.

After disabling it from "System > Config > Sales > Checkout" >Payment Methods Filter, changing Disable Payment Filter Extension to Yes I can see the Authorize.net payment method.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.