0

We have updated an older site to a new version of Magento and given it a new look. It is live and everything is working except I can't change any user roles. When I go into System->Permissions->Roles->Add role (or click on an existing role) I get a blank screen. If I turn php errors on in index.php file I get the following error:

Fatal error: Class 'Mage_Adminfee_Helper_Data' not found in /home/sites/website/public_html/app/Mage.php on line 547

And in the system log it shows this error:

Warning: include(Mage/Adminfee/Helper/Data.php): failed to open stream: No such file or directory  in /home/sites/gwebsite/public_html/lib/Varien/Autoload.php on line 93

Any advice would be appreciated.

Thanks

2

(shot in the dark) you have an extension called adminfee that has a section in the adminhtml.xml like this:

 <acl>
    <resources>
        <something_here translate="title" module="adminfee">
            <title>Some label here</title>
            <children>
    .....

but in the config.xml of the extension the helper alias is not defined.
you need to add this in config.xml of the extension inside the <global> tag.

<helpers>
    <adminfee>
        <class>[Namespace]_Adminfee_Helper</class>
    </adminfee>
</helpers>

replace [Namespace] with the real namespace of the module.

| improve this answer | |
  • Good shot in the dark, but sadly I checked the config.xml and it's already in there :( the module is kgn_adminfee – Ross Coulbeck Aug 10 '15 at 9:07
  • 1
    now we are getting somewhere. and what't the tag name under <helpers>? adminfee or kng_adminfee? – Marius Aug 10 '15 at 9:11
  • <adminfee> <class>Kgn_Adminfee_Helper</class> </adminfee> – Ross Coulbeck Aug 10 '15 at 9:27
  • Strange. It should work. Is the extension enabled? – Marius Aug 10 '15 at 10:19
  • Yes it's enabled, I've just tried disabling literally every possible 3rd party plugin on the site and it still does it. It might be something missing in Magento core code, running 1.8.1.0 by the way. – Ross Coulbeck Aug 10 '15 at 11:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.