3

i created a module in magento 1.9 CE to override list.php, and there was some issue, then i removed all the files for that module (the xml under module and all files under app/local/mycompany/), but the xml file keeps coming back with the following error:

    exception 'Mage_Core_Exception' with message 
'Invalid block type: MyCompany_MyCustomModule' in /Applications/MAMP/htdocs/magento/app/Mage.php:595

there is no MyCustomerModule anymore, but the system keep throwing the exception.

thanks a lot.

EDITED:

I did the following:

added these files:

app/etc/modules/MyCompany_CatalogList.xml

app/code/local/MyCompany/Catalog/etc/config.xml

app/code/local/MyCompany/Catalog/Block/Product/List/list.php

Then I reload the product category page, no products show (there should be some products). Then i went to the the above directory and deleted all the files.

Every time i try to load the page again, got that exception, but all the files are gone. I am confused.

enter image description here

  • Clear magento cache and session then try – MeenakshiSundaram R Jul 3 '15 at 16:59
  • i did try that, but the error still exists, even i completely removed all files and did the cache/session clean up. – triston Jul 3 '15 at 17:06
  • Did add any layout file with that module?? – MeenakshiSundaram R Jul 3 '15 at 17:12
  • 1
    Have you install Ames catalogproductlist module? – MeenakshiSundaram R Jul 3 '15 at 17:35
  • 1
    I will look into that once I get home. Thanks again for your help. – triston Jul 3 '15 at 17:55
2

If the Magento cache is disabled, there's two things that would cause this.

  • A proxy cache (like Varnish)
  • A opcache with file stat disabled

To fix the former, purge Varnish. To fix the latter, restart the PHP process (NB. file stat should be enabled anyway, the performance difference is negligible)

  • Thanks Ben, I don't really get what you mean. What should I do with your suggestion? – triston Jul 3 '15 at 18:27
  • Eek - I'm not really sure how to simplify it much more. Its probably best passing the comments on to your web host - they'll know how to interpret it. – Ben Lessani - Sonassi Jul 3 '15 at 18:46
  • thanks, just did. thanks to Meenakshi Sundaram R's troubleshooting as well. – triston Jul 3 '15 at 21:08
1

Clear your cache mechanisms, if files based just wipe var/cache/

  • i did, but it didn't help. – triston Jul 3 '15 at 17:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.