I have recently upgraded from 1.7 to 1.9 and now if I go to login or checkout, customer account ect I get the following error:

The page isn't redirecting properly

Firefox has detected that the server is redirecting the request for this address in a way that will never complete.

Admin works fine. Any Ideas what could be causing this?

I used these instructions :

  • What does your error log say? Mar 10, 2015 at 12:47
  • 2015-03-10T13:15:30+00:00 ERR (3): Recoverable Error: Argument 1 passed to Mage_Core_Model_Store::setWebsite() must be an instance of Mage_Core_Model_Website, null given, called in /var/sites/s/streetdecals.co.uk/public_html/app/code/core/Mage/Core/Model/App.php on line 634 and defined in /var/sites/s/streetdecals.co.uk/public_html/app/code/core/Mage/Core/Model/Store.php on line 453 Mar 10, 2015 at 13:21
  • I am assuming you updated your theme files for 1.9? They will not be the same Mar 10, 2015 at 14:00
  • The Theme files would have remained as I undertook a merge. A copy of 1.9 over the top of 1.7 Mar 10, 2015 at 14:17
  • So you updated you theme templates with the new version from 1.9? Mar 10, 2015 at 14:26

2 Answers 2


if I go to login or checkout, customer account ect I get the following error:

That's an infinite redirect for secure base urls. Usually caused by an incompatible combination of the "Secure base url" setting and a webserver redirect rule (i.e. .htaccess)

For example, one redirects from https to http, the other from http to https.


Make sure you have deleted


Make sure you have cleared or disabled your cache

Remove any cache folders from var/cache

If you have APC, REDIS or some other third party cache, please flush


I found this in addition to the above

UPDATE `core_store` SET store_id = 0 WHERE code='admin';
UPDATE `core_store_group` SET group_id = 0 WHERE name='Default';
UPDATE `core_website` SET website_id = 0 WHERE code='admin';
UPDATE `customer_group` SET customer_group_id = 0 WHERE customer_group_code='NOT LOGGED IN';

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.