1

I was wondering why my Magento local.xml is not being called. I have a package with multiple themes.

Package

  • Default
    • /layout/local.xml
  • Theme1
    • /layout/local.xml
  • Theme2
    • /layout/local.xml

I'm using Theme1 but the local.xml being called is from the Default theme. What I wanted was to use local.xml from Theme1. Any idea why this is not working?

2

Magento offers the possibility to use templates from one theme and layouts from an other one.
Even if this sounds nice, I don't think anyone uses it (I ma be wrong) because it can confuse the developers.
To avoid this, make sure that in System->Configuration->Design->Themes you set the same value for the fields Templates and Layout, the name of your theme.
If one of these is left blank the resources from the default theme will be used. (Theme1).

  • Thank you Marius for your reply. I've set the Templates, Skin, Layout to Theme1 but unfortunately this doesn't work. – magentoN00b Jul 8 '13 at 9:12
  • 1
    We use the type specific settings, but only for another fallback layer. I'm looking forward to limitless fallbacks in Magento 2. ;) – davidalger Jul 9 '13 at 0:04
  • Hi David can you expound what you meant by type specific? Does this mean that only the layout.xml in the Default theme gets recognized? Thank you. – magentoN00b Jul 9 '13 at 3:37
0

You should be able to have a local.xml file override for every theme directory - something is misconfigured or you have an error in your local.xml file.

Validate your XML file here

After you validate, you may want to turn on Magento Developer Mode to display future XML validation warnings.

http://alanstorm.com/magento_exception_handling_developer_mode

Aside from this, update the settings in System > Configuration > Design > Themes and point all of the field values to the same theme with the exception of default. Ensure that you have no values set under System > Design - which is meant to provide theme overrides on a scheduled basis (e.g. Holiday themes).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.