0

I installed a theme and after completely disabling the theme module by removing the etc/modules/.xml file. Then resetting the design back to default package and default theme in admin, the local.xml in default/default/layout doesn't load anymore.

What could the theme module change that would cause this?

2 Answers 2

0

Did your custom theme overwrite any of the files in the /app/design/frontend/default/default? Also, have you cleared your cache?

Also, that is NOT the way to disable a theme. Don't remove that file. Instead, open it and change true to false, then clear all caches: System > Cache Management.

3
  • No it doesn't overwrite anything. I cleared the cache, actually i just delete the whole cache folder. It regenerates. I have a folder inside etc/modules folder called OFF i drag a modules xml there to disable it that way it's easy and I can see which modules are disabled, plus just changing the module from true to false doesn't completely disable it.
    – Freejoy
    Feb 24, 2016 at 13:15
  • Depending on your server setup, this could be related to pagespeed or php-opcache. Are you running on a dedicated or cloud server? Also, check the permissions of your local.xml file. Feb 25, 2016 at 15:23
  • Thanks. i'm on a shared server with no cloud or cdn or opcache, my local.xml permissions is set at 644. Haven't been able to figure it out.
    – Freejoy
    Feb 29, 2016 at 7:15
0

I found the trouble, it was a mismatched tag :)
I forgot to add a </reference> closing tag. Apparently this is enough to cause the local.xml to not load because when i added the tag everything worked. I checked my local here: xmlgrid.net/validator.html

1
  • please edit your answer to add your comment so everyone knows how you fixed it Mar 17, 2016 at 19:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.