0

This is the what I receive as mail.

Dear Abc,

Welcome! Your e-mail has been verified. To log in to mysite.com just click Login or My Account at the top of every page, and then enter your e-mail address and password.

Here’s a record of your account details:
E-mail: abc@gmail.com
Password:
If you have any questions about your account or any other matter, please feel free to contact us at info@mysite.com

In my custom template i was added this line but its not displaying the value

Password: {{htmlescape var=$customer.password}}

Kindly help me to proceed. Magento ver 1.9.0.1..

1

This is new as of Magento CE 1.9.1.0. The password is no longer stored in plain text, but stored encrypted into the database (security reasons). Therefore the space behind the password in the confirmation email is blank. I guess the Magento Core Team forgot to remove this from the email templates.

You could remove the password label from the email template entirely or change the email template to something like this:

Password: The password you used to create your account

Also refer to this question and my answer.

  • Thank you..!But I need to show my password in that mail. What Shoid I do? – Shajitha Banu Feb 9 '15 at 4:54
0

Do not show the password in the email. Sending a password in an email is unsecure and a BAD idea. Instead you should change the email template to the Forgot Password email template so that the customer can reset the password, securely.

Configuration > Customers > Customer Configuration > Password Options

Forgot Email Template: Forgot Password

Remind Email Template: Forgot Password

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.