3

When i try to launch cron on magento 1.9.0.1 in crontab, I have this error :

...can't get apc memory size...

In my apc.ini, I have "apc.enabled=1", "apc.enable_cli = 0".

I know, I need to have "apc.enable_cli = 1" but I can't, instead I use :

/usr/bin/php -f /www/cron.php -d "apc.enable_cli=1"

But it doesn't work. It's really strange because on magento 1.7 this trick working well.

Do you have an idea why ?

0
1

The actual problem is, that php cli does use a different php.ini which you can find by running "php --ini"

I assume you did add it to the wrong ini

0

Oh, I found a solution to my own question. cron.php call cron.sh and cron.sh recall cron.php with specific parameters but don't care about parameter pass during the first call. I manually edit cron.sh and add -d "apc.enable_cli=1" where php command is called.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.