I am currently attempting to upgrade to the latest beta of 2.4.7.

However it only seems to recognize:

composer require-commerce magento/product-community-edition 2.4.7-beta2 --no-update

But when I then run

composer update --with-all-dependencies

I then get:

Problem 1
- Root composer.json requires magento/product-community-edition 2.4.7-beta2 -> satisfiable by magento/product-community-edition[2.4.7-beta2].
- magento/product-community-edition 2.4.7-beta2 requires magento/magento2-base 2.4.7-beta2 -> found magento/magento2-base[2.4.7-beta2] but it does not match your minimum-stability.

What is the correct approach? I followed this successfully to get from 2.4.5 to 2.4.6 without a problem:

I notice it states my version 2.4.5 but when I login to Magento it says 2.4.6?

My composer.json file is as follows:

    "name": "magento/project-community-edition",
    "description": "eCommerce Platform for Growth (Community Edition)",
    "type": "project",
    "license": [
    "config": {
        "allow-plugins": {
            "dealerdirect/phpcodesniffer-composer-installer": true,
            "laminas/laminas-dependency-plugin": true,
            "magento/*": true
        "preferred-install": "dist",
        "sort-packages": true
    "version": "2.4.5",
    "require": {
        "magento/composer-dependency-version-audit-plugin": "~0.1",
        "magento/composer-root-update-plugin": "~2.0",
        "magento/product-community-edition": "2.4.7-beta2",
    "autoload": {
        "exclude-from-classmap": [
        "files": [
        "psr-0": {
            "": [
        "psr-4": {
            "Magento\\": "app/code/Magento/",
            "Magento\\Framework\\": "lib/internal/Magento/Framework/",
            "Magento\\Setup\\": "setup/src/Magento/Setup/"
    "require-dev": {
        "allure-framework/allure-phpunit": "^2",
        "dealerdirect/phpcodesniffer-composer-installer": "^1.0",
        "dg/bypass-finals": "^1.4",
        "friendsofphp/php-cs-fixer": "^3.22",
        "lusitanian/oauth": "^0.8",
        "magento/magento-coding-standard": "*",
        "magento/magento2-functional-testing-framework": "^4.4.2",
        "pdepend/pdepend": "^2.10",
        "phpmd/phpmd": "^2.12.0",
        "phpstan/phpstan": "^1.9",
        "phpunit/phpunit": "^9.5",
        "sebastian/phpcpd": "^6.0",
        "symfony/finder": "^5.4"
    "conflict": {
        "gene/bluefoot": "*"
    "autoload-dev": {
        "psr-4": {
            "Magento\\PhpStan\\": "dev/tests/static/framework/Magento/PhpStan/",
            "Magento\\Sniffs\\": "dev/tests/static/framework/Magento/Sniffs/",
            "Magento\\TestFramework\\Inspection\\": "dev/tests/static/framework/Magento/TestFramework/Inspection/",
            "Magento\\TestFramework\\Utility\\": "dev/tests/static/framework/Magento/TestFramework/Utility/",
            "Magento\\Tools\\": "dev/tools/Magento/Tools/",
            "Magento\\Tools\\Sanity\\": "dev/build/publication/sanity/Magento/Tools/Sanity/"
    "minimum-stability": "stable",
    "prefer-stable": true,
    "extra": {
        "magento-force": "override"

1 Answer 1


You have to change the stability on your composer.json file to allow it to use less stable packages in order to get 2.4.7-beta.

"minimum-stability": "stable",
"prefer-stable": true,

Change this ^ to this:

"minimum-stability": "beta",
"prefer-stable": true,

Simple when you know how. Here is a list of the values accepted in minimum-stability which may differ depending on the package you are trying to use.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.