0

Anyone can tell me the steps to upgrade Magento Enterprise version 2.4.6-p4 to 2.4.6-p5? am I just only run below commands?

$ composer require "magento/magento-cloud-metapackage":"2.4.6-p5" --no-update

$ composer update

and then just run the composer update will do the job? Please help enter image description here

does this upgrade include the following security update release from Adobe? https://helpx.adobe.com/security/products/magento/apsb24-18.html

enter image description here

1 Answer 1

1

To upgrade Adobe Commerce on Cloud, use the following command format:

composer require "magento/magento-cloud-metapackage":">=CURRENT_VERSION <NEXT_VERSION" --no-update

For your specific case, where an upgrade to the latest patch release of version 2.4.6 is required, use this command:

composer require "magento/magento-cloud-metapackage":">=2.4.6 <2.4.7" --no-update

Then run composer update magento/magento-cloud-metapackage

If it does not work, you may need to run this command with the --with-dependencies param:

composer update magento/magento-cloud-metapackage --with-dependencies

You can check out the official documentation at https://experienceleague.adobe.com/en/docs/commerce-cloud-service/user-guide/develop/upgrade/commerce-version

Adobe Commerce and Magento Open Source version 2.4.6-p5 include fixes for all the security issues mentioned in the bulletin APSB24-18 https://helpx.adobe.com/security/products/magento/apsb24-18.html

8
  • HI Tu, I ran this command composer require "magento/magento-cloud-metapackage >=2.4.6-p5 <2.4.7" --no-update. But I got below error message Problem 1 - Root composer.json requires magento/magento-cloud-metapackage >=2.4.6-p5 <2.4.7, found magento/magento-cloud-metapackage[2.0.4, ..., 2.4.7] but it does not match the constraint.
    – Paul Fan
    Commented Apr 16 at 6:55
  • Hey Paul, try updating the ece-tools package before upgrading the Adobe Commerce version. Maybe it will resolve the issue. To update the ece-tools package, run the command: composer update magento/ece-tools --with-dependencies. experienceleague.adobe.com/en/docs/commerce-cloud-service/…
    – Tu Van
    Commented Apr 16 at 8:31
  • I did try and still no luck. Not sure why . It still showing Problem 1 - Root composer.json requires magento/magento-cloud-metapackage >=2.4.6-p5 <2.4.7, found magento/magento-cloud-metapackage[2.0.4, ..., 2.4.7] but it does not match the constraint.
    – Paul Fan
    Commented Apr 16 at 14:40
  • What about this? composer require magento/magento-cloud-metapackage >=2.4.6-p5 <2.4.7 --no-update && composer update magento/magento-cloud-metapackage --with-dependencies
    – Tu Van
    Commented Apr 16 at 14:44
  • I did try to roll back using 2.4.6 without the -p5. composer update can work properly. composer require "magento/magento-cloud-metapackage":">=2.4.6 <2.4.7" --no-update && composer update magento/magento-cloud-metapackage --with-dependencies
    – Paul Fan
    Commented Apr 16 at 15:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.