1
Uncaught Error: Mismatched anonymous define() module: function(){return cr}
https://requirejs.org/docs/errors.html#mismatch
    at makeError (require.js:168:17)
    at intakeDefines (require.js:1254:36)
    at require.js:1452:25
1
  • our store is also affected Jun 15, 2023 at 13:16

4 Answers 4

1

You can run the below command to disable it.

php bin/magento config:set admin/usage/enabled 0

If you want to disabled using Admin Go to Stores -> Configuration -> Admin -> Admin Usage -> Enable Admin Usage Tracking

enter image description here

You can also disable Magento_AdminAnalytics module using below command.

php bin/magento module:disable Magento_AdminAnalytics
0

I think in some where code like below

define(['jquery'], function ($) {
    'use strict';
});

Replace this

require(['jquery'], function($){
        //code here
});
2
  • understand but it is also showing with default magento install what will do on this case? Jun 16, 2023 at 6:28
  • php bin/magento config:set admin/usage/enabled 0; ....try after run this command and clear cache
    – MP Raj
    Jun 16, 2023 at 6:45
0

Apparently this is a new bug introduced today. It occurs with the inclusion of the Knowledge Centre feature, which has just appeared this morning for us. It is due to an Adobe change in an externally loaded JS file.

It occurs when Admin Usage Tracking is enabled in Admin Configuration. The best workaround at the moment is to simply set Admin Usage Tracking to No in the configs.

I've raised an issue at Github for this where other users are reporting the same. https://github.com/magento/magento2/issues/37618

0

It's an issues impacting the installations 2.4.4, 2.4.5, 2.4.6, 2.4.7 due to a JS conflict coming from http://assets.adobedtm.com/

A quick fix, for now, is to run these commands below and disable the admin tracking.

bin/magento config:set admin/usage/enabled 0;

bin/magento cache:clean;

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.