0

As soon as I enable FPC in Magento 2.4.2, I am getting a upstream sent too big header while reading response header from upstream error when I try searching. It does not happen for all search terms, but for most.

My shop is running on nginx so I tried adding this to the nginx.conf:

fastcgi_buffers 16 16k;
fastcgi_buffer_size 32k;
proxy_buffer_size   128k;
proxy_buffers   4 256k;
proxy_busy_buffers_size   256k;

Did not help a bit. Any ideas how to solve this?

Thanks!

0

I find this is normally down to the CSP headers. If you don’t need the module disable it using

bin/magento module:disable Magento_Csp

And you should be back in business.

1
  • Thanks, did not help in my case :( Sep 2 '21 at 6:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.