0

I'm currently using Magento 1.9. When i do a search in the search bar, search always returns me a page with all results(even above 900 results,so it's really really slow). Pagination of results appears but when i click on any page number it simply reshows me all the results...it seems like that pagination doesn't work! Could this behaviour depend on my installed Magento theme? Is there a way to programmatically fix this problem? Thank you.

  • Do you have any custom modules installed that might affect the search? I have a feeling that something loads the product collection before the pagination can add the limits. – Marius Aug 21 '14 at 13:46
  • I'm using Search Autocomplete + Search Suggest by Searchanise...could this be the cause? EDIT : Disabled it and tested, but i'm still getting the problem. – Mario Villani Aug 21 '14 at 14:06
  • did you disable it from the admin? or from app/etc/modules? Did you also clear the cache after disabling it? – Marius Aug 21 '14 at 14:12
  • Yes i did everything you said. – Mario Villani Aug 21 '14 at 14:20
  • Other ideas...suggestions? – Mario Villani Aug 25 '14 at 13:49
0

Problem was caused by this extension...uninstalling it made all work correctly! I recommend to NOT install it. http://www.magentocommerce.com/magento-connect/category-access-control.html

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.