FacebookBusiness extension was installed without problems a few days ago but no I have tried adding a different colour to my configurable product and keep getting this error.

Notice: Array to string conversion in /var/www/html/app/code/Facebook/BusinessExtension/Model/Feed/ProductFeed.php on line 107

            'main_image' => $this->_fbeHelper->getBaseUrlMedia() . 'catalog/product' . $mainImage,

this is a longer snippet

private function getProductImages(Product $product)
    $mainImage = $product->getImage();
    $additionalImages = [];

    foreach ($product->getMediaGalleryImages() as $img) {
        if ($img['file'] === $mainImage) continue;
    return [
        'main_image' => $this->_fbeHelper->getBaseUrlMedia() . 'catalog/product' . $mainImage,
        'additional_images' => array_slice($additionalImages, 0, 10)

Magento 2.3.6

1 Answer 1


I ran into the same Problem with the Facebook Business Extension 1.2.0. Upgrading it to 1.2.3 (download from https://www.facebook.com/business/help/532749253576163) solved it for me.

  • yes, same here, the latest version from FB doesn't throw an error) Mar 3, 2021 at 9:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.