0

I need to use a layout update for cms page.

I've created a file called cms_page_view_selectable_home_HomePageBlocks.xml

<?xml version="1.0" encoding="utf-8"?>
<page xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:noNamespaceSchemaLocation="urn:magento:framework:View/Layout/etc/page_configuration.xsd">
    <referenceContainer name="page.wrapper">
      <container name="main-content-outer" before="main.content">
        <block class="Magento\Cms\Block\Block" name="tm_slider">
            <arguments>
                <argument name="block_id" xsi:type="string">tm_slider</argument>
            </arguments>
        </block>
        <block class="Magento\Cms\Block\Block" name="tm_category_banner_cms">
                 <arguments>
                      <argument name="block_id" xsi:type="string">tm_category_banner_cms</argument>
                 </arguments>
           </block>
            <block class="Magento\Cms\Block\Block" name="tm_subbanner_CMS">
            <arguments>
                <argument name="block_id" xsi:type="string">tm_subbanner_CMS</argument>
            </arguments>
        </block>
           <block class="Magento\Cms\Block\Block" name="tm_special_cms">
                <arguments>
                     <argument name="block_id" xsi:type="string">tm_special_cms</argument>
                </arguments>
             </block>
             <block class="Magento\Cms\Block\Block" name="tm_homepage_service_cms">
            <arguments>
                <argument name="block_id" xsi:type="string">tm_homepage_service_cms</argument>
            </arguments>
        </block> 
        <block class="Magento\Cms\Block\Block" name="tm_Products_CMS">
            <arguments>
                <argument name="block_id" xsi:type="string">tm_Products_CMS</argument>
            </arguments>
        </block>  
        <block class="Magento\Cms\Block\Block" name="tm_Singlebanner_CMS">
            <arguments>
                <argument name="block_id" xsi:type="string">tm_Singlebanner_CMS</argument>
            </arguments>
        </block>
        <block class="Magento\Cms\Block\Block" name="tm_manufacture">
            <arguments>
                <argument name="block_id" xsi:type="string">tm_manufacture</argument>
            </arguments>
        </block>
        <block class="Magento\Cms\Block\Block" name="tm_blog">
            <arguments>
                <argument name="block_id" xsi:type="string">tm_blog</argument>
            </arguments>
        </block>
      </container>
    </referenceContainer>
</page>

I'm able to selecte it in CMS Page Edit Form, but nothing shows in frontend.

There is something wrong?

1 Answer 1

0

IT IS A BUG

found the solution at:

https://github.com/magento/magento2/commit/53c78d534063efa1d8275e27f9cd019dfd9000dc

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.