0

I created a CMS page from the adminpanel.

enter image description here

After that i created a CMS block using the admin panel. Both worked fine. Then i created a new Category and inside the category form i added the previous generated CMS Block in the "Add CMS Block" Dropdown. In "Display Mode" i selected "Static block only".

The static Block and the Top menu is created like expected, but the Category Title is displayed below of the CMS Block. I want to show the Category Title above the CMS Block.

How can i achieve this ?

6
  • Provide more information about in details or provide the screenshot or video of the issue which you are facing.
    – Nits
    Nov 13, 2019 at 12:55
  • When i was created new top menu.
    – Praful
    Nov 13, 2019 at 12:57
  • Please provide a screenshot, this information is not enough. If you want to display category in the top navigation menu then there is a feature call displaying menu at category edit page in the backend, once you enable, it will display in the frontend top navigation.
    – Nits
    Nov 13, 2019 at 12:59
  • i've edited the post, now its more understandable and the information is far enough now. The issue is that the category title is displayed below the cms block instead of above.
    – Ekk4rd
    Nov 13, 2019 at 13:01
  • yes right . How do that?
    – Praful
    Nov 13, 2019 at 13:04

1 Answer 1

0

Please search catalog_category_view.xml or create a new file:

app/design/frontend/Package/theme in that create a file with name catalog_category_view.xml at below location

app/design/frontend/Package/theme/Magento_Catalog/view/frontend/layout

And put this code there in the file catalog_category_view.xml

<page xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" layout="2columns-left" xsi:noNamespaceSchemaLocation="urn:magento:framework:View/Layout/etc/page_configuration.xsd">
    <body>
    <move element="columns.top" destination="content" before="-"/>
    </body>
</page>

Note: Please run the below commands.

php bin/magento cache:flush
php bin/magento setup:static-content:deploy -f

Please let me know if you still facing the same issue.

5
  • thank you so for the solution its work me
    – Praful
    Nov 14, 2019 at 6:10
  • I have one more issue, I want add default Contact Us into the Top menu but Not Working? Anyone idea how to configuration?
    – Praful
    Nov 14, 2019 at 6:58
  • This is the answer to your question then, Please accept this as an answer so it will help others.
    – Nits
    Nov 14, 2019 at 13:36
  • its working for me. Thanks for the solutions
    – Praful
    Nov 22, 2019 at 8:35
  • Please accept this as solution if it is working for you.
    – Nits
    Nov 22, 2019 at 9:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.